Po upgradu konzole Dell Security Management Server Virtual z verze 9.11 na verzi 10.0.0.29 se nedaří spustit službu Core Server a Inventory Server.

Summary: Tento článek pojednává o upgradu nástroje Dell Security Management Server Virtual z verze v9.11 na verzi 10.0.0.29 a nespustí se hlavní server a inventarizační server.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Dotčené produkty:

  • Dell Security Management Server Virtual

Dotčené verze:

  • v10.0.0.29

Při online upgradu nástroje Dell Security Management Server v9.11 na verzi 10.0.0.29 se nespustí základní server a server inventáře, i když se upgrade zdá být úspěšně dokončen.

Cause

Chcete-li ověřit, zda byly spuštěny služby Core Server and Inventory Server, připojte se ke konzoli delluser pro virtuální správu nástroje Dell Security Management Server a vyberte možnost System Dashboard.

Nepodařilo se spustit hlavní server a inventarizační server
Obrázek 1: (Pouze v angličtině) Nepodařilo se spustit hlavní server a inventarizační server

Dostupnost nekompatovatelné verze mono online vyšší než v5.14.0.177 během procesu upgradu to způsobuje.

Chcete-li ověřit, zda je nainstalovaná verze Mono vyšší než 5.14.0.177, postupujte následovně:

  1. Připojte se k konzoli delluser pro virtuální správu nástroje Dell Security Management Server a vyberte možnost Launch Shell.

Výběr možnosti Launch Shell
Obrázek 2: (Pouze v angličtině) Výběr možnosti Launch Shell

  1. Do prostředí zadejte příkaz mono --version

SLN314455_en_US__3ddpkm2052c
Obrázek 3: (pouze v angličtině) mono --version

 

Resolution

Pokud je verze vyšší než 5.14.0.177, vyřešte problém pomocí níže uvedených kroků.

  1. Chcete-li skript získat, obraťte se na install_mono_5.14.0.177.sh podporu Dell Pro.
  2. Pomocí aplikace FTP zkopírujte skript do složky podpory v aplikaci Dell Security Management Server Virtual:

Přesun skriptu do složky podpory pomocí klienta FTP
Obrázek 4: (Pouze v angličtině) Přesun skriptu do složky podpory pomocí klienta FTP

  • Adresu IP konzole Dell Security Management Server Virtual naleznete na řídicím panelu Dell Security Management Server Virtual.
  1. Pokud není v aplikaci Dell Security Management Server Virtual povolen protokol FTP, povolte jej následujícím způsobem:
    1. Připojte se ke konzoli pro virtuální správu nástroje Dell Security Management Server jako delluser.
    2. Vyberte možnost Basic Configuration > SFTP.

Vyberte možnost SFTP.
Obrázek 5: (Pouze v angličtině) Vyberte možnost SFTP.

  1. Přidejte uživatele FTP, který specifikuje uživatele a heslo, a výběrem možnosti Apply.

Přidání uživatele a uživatele FTP
Obrázek 6: (Pouze v angličtině) Přidání uživatele a uživatele FTP

  1. Otevřete prostředí z konzole pro správu Dell Security Management Server Virtual:

Výběr možnosti Launch Shell
Obrázek 7: (Pouze v angličtině) Výběr možnosti Launch Shell

  1. Spusťte skript pomocí následujících kroků:
su dellsupport
  • Vložte heslo ( dellsupport výchozí heslo dellsupport).
cd /var/opt/dell/dsmsv/ftp/files/support/
sudo chmod +x install_mono_5.14.0.177.sh
sudo ./install_mono_5.14.0.177.sh
  1. Počkejte na dokončení skriptu.
  2. Zadáním příkazu mono --versionpotvrďte, že nainstalovanou verzí mono je 5.14.0.177.

Typ mono --version
Obrázek 8: (Pouze v angličtině) Zadejte mono --version

  1. V části System Dashboard zkontrolujte, zda jsou nyní spuštěny služby Core Server a Inventory Server:

Základní server a inventarizační server nebo spuštěný
Obrázek 9: (Pouze v angličtině) Základní server a inventarizační server nebo spuštěný


Chcete-li kontaktovat podporu, přečtěte si článek Telefonní čísla mezinárodní podpory Dell Data Security.
Přejděte na portál TechDirect a vygenerujte online žádost o technickou podporu.
Další informace a zdroje získáte na fóru komunity Dell Security.

Additional Information

Videos

 

Affected Products

Dell Encryption
Article Properties
Article Number: 000130513
Article Type: Solution
Last Modified: 10 Oct 2023
Version:  11
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.