After Upgrading Dell Security Management Server Virtual From v9.11 to 10.0.0.29, Core Server and Inventory Server Fail to Start

Summary: This article discusses upgrading Dell Security Management Server Virtual from v9.11 to 10.0.0.29 and the core server and inventory server fails to start.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Affected Products:

  • Dell Security Management Server Virtual

Affected Versions:

  • v10.0.0.29

The Core Server and the Inventory Server fail to start, when performing an online upgrade of the Dell Security Management Server v9.11 to 10.0.0.29, even though the upgrade seems to be completing successfully.

Cause

To verify that the Core Server and Inventory Server services have started, connect to the Dell Security Management Server Virtual Administration Console with delluser and select System Dashboard.

Core Server and Inventory Server Failed to start
Figure 1: (English Only) Core Server and Inventory Server Failed to start

The online availability of a noncompatible Mono version higher than v5.14.0.177 during the upgrade process causes this.

To confirm that the installed version of Mono is higher than 5.14.0.177, follow the below steps:

  1. Connect on the Dell Security Management Server Virtual Administration Console as delluser and select Launch Shell.

Select Launch Shell
Figure 2: (English Only) Select Launch Shell

  1. In the shell, type mono --version

SLN314455_en_US__3ddpkm2052c
Figure 3: (English Only) type mono --version

 

Resolution

If the version showing is higher than 5.14.0.177, apply the steps below to resolve the issue.

  1. Contact Dell Pro Support to obtain the install_mono_5.14.0.177.sh script.
  2. Use an FTP application to copy the script to the support folder on the Dell Security Management Server Virtual:

Move script to support folder using FTP client
Figure 4: (English Only) Move script to support folder using FTP client

  • The IP address of the Dell Security Management Server Virtual can be found in the Dell Security Management Server Virtual System Dashboard.
  1. If the FTP is not enabled on the Dell Security Management Server Virtual, enable it by following the steps below:
    1. Connect to the Dell Security Management Server Virtual Administration Console as delluser.
    2. Select Basic Configuration > SFTP.

Select SFTP
Figure 5: (English Only) Select SFTP

  1. Add an FTP user specifying a User and Password, and selecting Apply.

Add and FTP User
Figure 6: (English Only) Add and FTP User

  1. Open the shell from the Dell Security Management Server Virtual Administration Console:

Select Launch Shell
Figure 7: (English Only) Select Launch Shell

  1. Run the script using the steps below:
su dellsupport
  • Insert the password for dellsupport (default password dellsupport).
cd /var/opt/dell/dsmsv/ftp/files/support/
sudo chmod +x install_mono_5.14.0.177.sh
sudo ./install_mono_5.14.0.177.sh
  1. Wait for the script to complete.
  2. Confirm that the installed version of Mono is the 5.14.0.177 by typing the command mono --version.

Type mono --version
Figure 8: (English Only) Type mono --version

  1. Check in the System Dashboard if the Core Server and Inventory Server are now running:

Core Server and Inventory Server or running
Figure 9: (English Only) Core Server and Inventory Server or running


To contact support, reference Dell Data Security International Support Phone Numbers.
Go to TechDirect to generate a technical support request online.
For additional insights and resources, join the Dell Security Community Forum.

Additional Information

Affected Products

Dell Encryption
Article Properties
Article Number: 000130513
Article Type: Solution
Last Modified: 10 Oct 2023
Version:  11
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