Bad System Config Info Error on Dell Encryption Enterprise and Personal Endpoints

Summary: Devices running Dell Encryption Enterprise or Dell Encryption Personal may resolve BAD_SYSTEM_CONFIG_INFO errors by following these instructions.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Affected Products:

  • Dell Encryption Enterprise
  • Dell Encryption Personal

Affected Versions:

  • v10.3.1 and Earlier

Resolved Versions:

  • v10.4.0 and Later

Affected Operating Systems:

  • Windows 10 version 1903 (May 2019 Update/19H1)

Endpoints using Dell Encryption Enterprise or Dell Encryption Personal on Windows 10 version 1903 (May 2019 Update / 19H1) or later may display a blue screen operating system failure BAD SYSTEM CONFIG INFO (BAD_SYSTEM_CONFIG_INFO) after installing Windows operating system updates from August 2019 and later.

Cause

A new file class introduced by Microsoft for Windows 10 version 1903 (May 2019 Update/19H1) and later in the August 2019 operating system updates cause System Data Encryption (SDE) checksums to be unable to validate system files that have been reclassified using this new identifier, and results in a blue screen.

Windows Error screen
Figure 1: (English Only) Windows Error screen

 

Resolution

Dell Encryption v10.4.0 and later supports Microsoft’s new file classification. Installing v10.4.0 before installing updates that contain the new file classification prevents the BAD SYSTEM CONFIG INFO blue screen.

Alternatively, installing Windows operating system updates from August 2019 and later before installing Dell Encryption also prevents the blue screen failure.

If an endpoint is affected, by a BAD SYSTEM CONFIG INFO blue screen, a local security administrator (LSA) recovery can be performed to resolve the blue screen. For more information about the recovery process, reference How to Run the Dell Encryption Enterprise / Dell Encryption Personal Recovery Bundle.


To contact support, reference Dell Data Security International Support Phone Numbers.
Go to TechDirect to generate a technical support request online.
For additional insights and resources, join the Dell Security Community Forum.

Affected Products

Dell Encryption
Article Properties
Article Number: 000130827
Article Type: Solution
Last Modified: 02 Oct 2023
Version:  9
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.