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PowerEdge - How to generate servers logs with the iDRAC?

Summary: Dell PowerEdge servers provide several hardware reports that can be viewed and exported via the integrated Dell Remote Access Controller (iDRAC). These logs are useful forSee more

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Article Content


Symptoms

Table of Contents:

  1. System Event Log

  2. Lifecycle Controller Log

  3. SupportAssist Collection and RAID Controller Log

 

1. System Event Log

When a system event occurs on a managed system, it is recorded in the System Event Log (SEL). The SEL page displays a system health indicator, a time stamp, and a description for each event logged. The same SEL entry is also available in the Lifecycle Controller (LC) log.

 

Follow these steps to view, export and clear the SEL, in iDRAC Web interface:

 
  1. Enter the iDRAC web interface
     
  2. Go to Overview > Server > Logs
     
  3. The first page shown is the Server Event Log (SEL)
     
  4. Click Save As on the bottom of the list to save the SEL to a location of your choice
     
  5. To clear the logs, click Clear Log on the bottom of the list (this option only appears if you have the permission)


     

 

Cause

2. Lifecycle Controller Log

Lifecycle Controller logs provide the history of changes related to components installed on a managed system. It provides logs about events related to:

  • Storage Devices
  • System events
  • Network Devices
  • Configuration
  • Audit
  • Updates
  • Work notes

     

You can export the entire Lifecycle Controller log (active and archived entries) in a single zipped XML file to a network share or to the local system. The zipped XML file extension is .xml.gz. The file entries are ordered sequentially based on their sequence numbers, ordered from the lowest sequence number to the highest.

 

Follow these steps to export the Lifecycle Controller log:
 
  1. Enter the iDRAC web interface
     
  2. Go to Overview > Server > Logs
     
  3. Click on the Lifecycle Log tab
     
  4. In the Lifecycle Log page, click Export
     
  5. Select any of the following options:
    • Network — Export the Lifecycle Controller logs to a shared location on the network
    • Local — Export the Lifecycle Controller logs to a location on the local system
SLN305828_en_US__1icon Note: While specifying the network share settings, it is recommended to avoid special characters for user name and password or percent encode the special characters.
  1. Click Export to export the log to the specified location

 

Resolution

3. SupportAssist Collection and RAID Controller Log

SupportAssist Collection (formely known as Tech Support Report / TSR) and the RAID Controller log provide detailed information about the status of system, firmware and storage. Especially the RAID log is the most requested report by Dell support for troubleshooting storage issues.
 

For exporting the SupportAssist Collection and the RAID log, follow the steps described in this article  (incl. video).

 

Article Properties


Affected Product

PowerEdge

Last Published Date

07 Oct 2021

Version

5

Article Type

Solution