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Dell PowerEdge: "No Boot Device Available" is displayed during startup

Summary: Here you find how to fix "No boot device found" issues on Dell PowerEdge servers by selecting the correct boot source and troubleshooting common failures.

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Article Content


Symptoms

This article explains how to troubleshoot a "no boot" situation. It means that the server powers on and the Dell screen appears but when the operating system should be loaded, the error "No Boot Device Available" is displayed and nothing happens. No power and no post issues are explained in this article: Troubleshooting a Server that does not start.

SLN292433_en_US__1icon Note: If it is necessary to reinstall the operating system, just follow the steps provided in the dedicated article How to install the operating system on a Dell PowerEdge Server? (OS deployment).

 

Cause

After completing the Power On Self-Test (POST) phase, the server tries to boot a bootable device.A boot device is any piece of hardware that can read or contains the files required for a computer to start. A default bootable media can be select in the BIOS and by default the raid controller card (PERC) will be selected first. Files available in a bootable device (RAID, USB key, DVD, ISO file) contain instructions to start the operating system. When these files cannot be found, the error "No Boot Device Available" is displayed.
Few actions can be performed to check what is not working properly.

Resolution

Manually select the boot device

The first thing to check is which device is selected as the primary boot. To do a quick check please use F11 to launch the manual boot selection.

  1. Restart the system
  2. Press F11 during POST to enter the Boot Manager
  3. Select the correct Hard Disk drive (Virtual Drive), where the OS is installed
  4. Boot from this device

If the system now boots into the operating system, the hardware is fine and there is a boot order conflict in the BIOS settings. The most likely cause for this is that the system is set to boot from CD/DVD and/or USB before the drives, which is a logical setting. To resolve this, just ensure you do not have a USB or CD/DVD inserted into the system.

Note: The Error can be caused by wrong settings in the boot mode, too. An OS installed in UEFI mode cannot boot in BIOS mode and vice versa.

You can change the boot order setting permanently in the System Setup to boot from the drive first. To change this:

  1. Restart the system
  2. Press F2 during system start to enter the System Settings
  3. Change the Boot Sequence in the Boot Settings
  4. Leave the menu via Exit in the upper right corner of the screen
Note: After this, you will require pressing F11 if you wish to boot from a CD/DVD or USB at a later date.


 



Troubleshoot RAID issues

If the server was working properly and without any change, the issue arises, the RAID properties needs to be checked

Checking hard drive status in the PERC BIOS

Press Ctrl + R during the POST process to open PERC BIOS Configuration Utility.

SLN292433_en_US__2a1


To check if the hard drive is participating in the RAID array, perform the following steps: a Press Ctrl + N to go to the PD Mgmt (Physical Disk Management) screen and check if any hard drives are offline or missing

SLN292433_en_US__3a2

On this page, check that the Virtual Disk is online in an optimal state.
More information about How to identify an HDD failure and solve the issue is available in this article. 

When the RAID is managing multiple VD, it is important to select which VD has to be presented when the server tries to boot on the raid controller.
The bootable Virtual Disk can be selected on the last tab "CTRL Mgmt". It is important to select the VD where the operating system is installed.

If the RAID is working fine, the operating system files have to be investigated as the last step. If there is any doubt regarding the server hardware, it is possible to boot on the Support Live Image ( How to download and run the Support Live Image on a Dell PowerEdge ) to start the troubleshooting.

Article Properties


Affected Product

PowerEdge

Last Published Date

28 Jan 2022

Version

6

Article Type

Solution