Symptoms
A failed drive (hard drive or SSD) in a VxRail node caused the VSAN object corruption.
- Capacity drive failure on a VSAN deduplication-disabled cluster causes one copy of an object missing with a reduced object situation.
- Capacity drive failure on a VSAN deduplication-enabled cluster causes the whole disk group failure.
- Cache drive failure on the VSAN irrespective of deduplication enabled or not causes the whole disk group failure.
All above situations may have the potential of data unavailability or data loss on the customer production data.

VxRail dials-home to Dell with error code MYSTIC020002
or VXR020002
when a disk's (hard drive or SSD) hardware status changes from "Normal" status.
Cause
This dial-home event is generated when the status of one of the SSD or hard drive within a VxRail node changes. This possibly indicates a failed or failing drive and may require replacement.
Dell support verifies a failed SSD or hard drive and dispatches for disk replacement if necessary. If a disk has failed, the SSD or hard drive LED light flashes slowly with an amber color.
Resolution
Use these steps to address the issue:
- Connect to VxRail remotely, if available.
- Open vSphere
- Click the node that generated the dial-home.
- Click Monitor Tab.
- Click Hardware Status Tab.
- Select Sensors from the left pane and expand Storage, look through the list to find any Storage devices in a warning or error state.
- Highlight the VSAN cluster and go to Configure Tab and choose Disk management under VSAN then check all the node, disk group, and disk status if any error is visible along with its status
- Go to VSAN cluster and Monitor Tab and run the skyline health check to see the VSAN disk status of all the nodes.
Reseating the hard drive cable may resolve the issue. Clear the logs and alerts then check to determine if the error persists.
If any of the storage devices are in a warning or error state, work order the SR for drive replacement.
If any assistance on troubleshooting the issues above is required, contact Dell Technical Support or your Authorized Service Representative, and quote this KB article ID.
Affected Products
VxRail Appliance Family
Products
VxRail Software