La sauvegarde invité Avamar de la machine virtuelle s’exécute lentement et expire en raison d’un goulot d’étranglement au niveau des ressources matérielles (en anglais)
Summary: Une sauvegarde invité Avamar d’une machine virtuelle s’exécute lentement, en raison d’un goulot d’étranglement des ressources matérielles.
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Symptoms
Une machine virtuelle sur laquelle un client Avamar est installé dans le système d’exploitation invité présente des performances erratiques ou médiocres.
Si la sauvegarde atteint la fin de la fenêtre de sauvegarde sans se terminer, Avamar signale que la sauvegarde échoue avec le délai d’expiration - fin.
Exemple:-
Ci-dessous, nous passons en revue les logs d’un client qui a rencontré un comportement erratique depuis sa virtualisation.
Vous trouverez ci-dessous une sauvegarde rapide et une sauvegarde lente pour le même client.
Le log de la sauvegarde rapide affiche un taux de performances maximal de 2 291 881 fichiers par heure. Le taux de modification des fichiers et des données dans cette sauvegarde est faible.
Les messages d’état des logs indiquent qu’au cours de la sauvegarde, le taux d’analyse des fichiers est constant, sans périodes rapides ou lentes.
L’utilisation du processeur est également raisonnablement constante et reste comprise entre 40 et 60 %.
Vous trouverez ci-dessous une démonstration graphique à l’aide d’un outil Dell interne qui analyse les journaux du client Avamar et les graphiques des données.
Ces graphiques montrent que, dans de bonnes conditions, la sauvegarde s’exécute rapidement.
Le système de stockage alimente avtar avec des fichiers à une vitesse qui maintient le processeur à un niveau d’utilisation modérément élevé.
Ensuite, nous passons en revue le log pour rechercher la sauvegarde plus lente. Cette sauvegarde concerne les mêmes données clientes, mais dans des conditions de chargement du matériel virtuel différentes. Nous constatons que les performances des fichiers/heures sont <de 400 000 fichiers/heure.
Comme le taux de modification est faible, similaire à la sauvegarde rapide, les comportements de sauvegarde sont comparables.
Sous le log, une représentation graphique montre que les performances de sauvegarde commencent rapidement, puis ralentissent (zone mise en surbrillance dans la zone rouge).
Les performances lentes des fichiers par heure sont corrélées précisément avec la période de 11 h 00 à 19 h 00.
Notez que de 11 h à 19 h, l’utilisation du processeur passe de plus de 40 % à environ 5 à 10 %.
Après 19 h, l’utilisation du processeur varie de 15 à 20 % et les performances des fichiers par heure augmentent, mais pas aussi élevées que lors de la partie initiale de la sauvegarde.
Si la sauvegarde atteint la fin de la fenêtre de sauvegarde sans se terminer, Avamar signale que la sauvegarde échoue avec le délai d’expiration - fin.
Exemple:-
Ci-dessous, nous passons en revue les logs d’un client qui a rencontré un comportement erratique depuis sa virtualisation.
Vous trouverez ci-dessous une sauvegarde rapide et une sauvegarde lente pour le même client.
Le log de la sauvegarde rapide affiche un taux de performances maximal de 2 291 881 fichiers par heure. Le taux de modification des fichiers et des données dans cette sauvegarde est faible.
2015-09-14 00:49:20 avtar Info <5156>: Backup #12 timestamp
2015-09-14 00:49:20, 13,050,798 files, 1,352,497 folders, 9,671 GB (37,919 files, 437.1 MB, 0.00% new)
2015-09-14 00:49:20 avtar Info <6083>: Backed-up 9,671 GB in 341.66 minutes: 1,698 GB/hour (2,291,881 files/hour)
Les messages d’état des logs indiquent qu’au cours de la sauvegarde, le taux d’analyse des fichiers est constant, sans périodes rapides ou lentes.
L’utilisation du processeur est également raisonnablement constante et reste comprise entre 40 et 60 %.
Vous trouverez ci-dessous une démonstration graphique à l’aide d’un outil Dell interne qui analyse les journaux du client Avamar et les graphiques des données.
Ces graphiques montrent que, dans de bonnes conditions, la sauvegarde s’exécute rapidement.Le système de stockage alimente avtar avec des fichiers à une vitesse qui maintient le processeur à un niveau d’utilisation modérément élevé.
Ensuite, nous passons en revue le log pour rechercher la sauvegarde plus lente. Cette sauvegarde concerne les mêmes données clientes, mais dans des conditions de chargement du matériel virtuel différentes. Nous constatons que les performances des fichiers/heures sont <de 400 000 fichiers/heure.
Comme le taux de modification est faible, similaire à la sauvegarde rapide, les comportements de sauvegarde sont comparables.
Sous le log, une représentation graphique montre que les performances de sauvegarde commencent rapidement, puis ralentissent (zone mise en surbrillance dans la zone rouge).
2015-09-22 07:41:35 avtar Info <5157>: PARTIAL Backup #35 timestamp
2015-09-22 07:41:35, 9,190,850 files, 1,030,683 folders, 8,283 GB (22,390 files, 397.8 MB, 0.00% new)
2015-09-22 07:41:35 avtar Info <6083>: Backed-up 8,283 GB in 1440.19 minutes: 345 GB/hour (382,902 files/hour)

Les performances lentes des fichiers par heure sont corrélées précisément avec la période de 11 h 00 à 19 h 00.
Notez que de 11 h à 19 h, l’utilisation du processeur passe de plus de 40 % à environ 5 à 10 %.
Après 19 h, l’utilisation du processeur varie de 15 à 20 % et les performances des fichiers par heure augmentent, mais pas aussi élevées que lors de la partie initiale de la sauvegarde.
Cause
Le dataset de notre « exemple client » est prévisible et le taux de modification est négligeable. Le client effectue une quantité de travail similaire chaque jour,
Les performances erratiques observées sont dues à des conflits d’accès pour les ressources matérielles partagées utilisées par Avamar lors de l’analyse des fichiers.
Dans l’exemple ci-dessus, les ressources matérielles sont soit en forte demande, soit limitées pour le client pendant les heures de pointe.
Le comportement dépend des ressources disponibles. La ressource la plus susceptible d’être goulot d’étranglement est les demandes d’E/S de recherche aléatoires sur le périphérique de stockage où se trouvent les données.
Si l’utilisation du processeur augmente en heures de pointe, le goulot d’étranglement peut être dû à une pénurie de partages de CPU disponibles pour la machine virtuelle.
Les performances erratiques observées sont dues à des conflits d’accès pour les ressources matérielles partagées utilisées par Avamar lors de l’analyse des fichiers.
Dans l’exemple ci-dessus, les ressources matérielles sont soit en forte demande, soit limitées pour le client pendant les heures de pointe.
Le comportement dépend des ressources disponibles. La ressource la plus susceptible d’être goulot d’étranglement est les demandes d’E/S de recherche aléatoires sur le périphérique de stockage où se trouvent les données.
Si l’utilisation du processeur augmente en heures de pointe, le goulot d’étranglement peut être dû à une pénurie de partages de CPU disponibles pour la machine virtuelle.
Resolution
- Exécutez la sauvegarde en dehors des heures de forte activité et (si possible), lorsque le client n’est pas fortement occupé par ses tâches habituelles.
- Assurez-vous que l’hyperviseur de la machine virtuelle n’applique pas de limites de CPU, de mémoire ou d’E/S au moment de la fenêtre de sauvegarde.
- Évitez les sauvegardes Avamar qui se chevauchent avec des périodes d’activité élevée où les conflits d’accès au stockage partagé sont élevés.
- Pour les applications à faible taux de modification, envisagez d’utiliser une sauvegarde basée sur image. L’appliance proxy de sauvegarde d’image sauvegarde uniquement les blocs modifiés. Il n’analyse pas tous les fichiers du Dataset, ce qui réduit les exigences d’E/S.
Additional Information
Pour plus d’informations sur la procédure d’enquête sur les problèmes de performances de sauvegarde Avamar, reportez-vous à la section ;
Pour plus d’informations sur l’analyse et l’interprétation des messages d’état avtar ;
Pour plus d’informations sur l’analyse et l’interprétation des messages d’état avtar ;
Affected Products
AvamarProducts
AvamarArticle Properties
Article Number: 000164580
Article Type: Solution
Last Modified: 10 Feb 2025
Version: 4
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