「Data Domain:クライアントSNMPリクエストが「不明なホスト」エラーで失敗する |Dpa
Summary: この記事では、リモート エージェントを使用してData Domainシステムをターゲットとする場合に、ホスト名解決エラーでSNMPステータス リクエストが失敗する理由について説明します。この問題は通常、エージェント ホストにターゲット システムのホスト名とIPアドレスの適切なマッピングがない場合に発生します。
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
-
特定のData Domainシステムで、SNMPステータス リクエストが一貫して失敗します。
-
UIでは、リクエスト履歴に次のエラーが表示されます。
Could not contact SNMP service on host <DD_hostname>: Unknown host (<DD_hostname>) -
デバッグ ログ
dpaagent次のようなエラーを表示します。getaddrinfo: <DD_hostname> Hostname and service name not provided or found aapiSNMPOpen(): Failed to open SNMP session for host '<DD_hostname>', errno 0, snmp_error 'Unknown host (<DD_hostname>)'
Cause
エージェント ホストのローカル ホスト ファイルにData Domainシステムのエントリーがありません。その結果、ホスト名をIPアドレスに解決できず、SNMPセッションの初期化が失敗します。
Resolution
Data DomainシステムのIPアドレスとホスト名をエージェント ホストのhostsファイルに追加します。
SNMPホスト名解決の詳細については、 Microsoftのドキュメント (Ext Link)を参照してください。SNMPは、Windows Internet Naming Service(WINS)またはローカル ホスト ファイルを使用してホスト名を解決します。WINSが使用できない場合は、ホスト ファイルに正しいマッピングが含まれている必要があります。
ベスト プラクティス:
SNMP管理アプリケーションでは、IPアドレスの代わりにホスト名を使用します。すべての参加システムのホスト ファイルに、ホスト名とIPアドレスの正確なマッピングがあることを確認します。
次のステップ:
hostsファイルをアップデートした後も問題が解決しない場合は、Dellテクニカル サポート チームにお問い合わせください。
Affected Products
Data Domain, Data Protection AdvisorProducts
Data Protection Suite Series, Integrated Data Protection Appliance FamilyArticle Properties
Article Number: 000168556
Article Type: Solution
Last Modified: 18 Nov 2025
Version: 3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.