Data Domain: Client-SNMP-Anforderung schlägt mit Fehler "Unbekannter Host" fehl | DPA

Summary: In diesem Artikel wird erläutert, warum SNMP-Statusanfragen möglicherweise mit einem Auflösungsfehler fehlschlagen, wenn ein Data Domain-System mithilfe eines Remote-Agent als Ziel verwendet wird. Das Problem tritt in der Regel auf, wenn der Agent-Host keine ordnungsgemäße Hostname-zu-IP-Zuordnung für das Zielsystem aufweist. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • SNMP-Statusanfragen schlagen für ein bestimmtes Data Domain-System immer wieder fehl.

  • Die Benutzeroberfläche zeigt den folgenden Fehler im Anforderungsverlauf an:

    Could not contact SNMP service on host <DD_hostname>: Unknown host (<DD_hostname>)
    
  • Debug-Protokolle von dpaagent Zeigen Sie Fehler an, wie z. B.:

    getaddrinfo: <DD_hostname> Hostname and service name not provided or found
    aapiSNMPOpen(): Failed to open SNMP session for host '<DD_hostname>', errno 0, snmp_error 'Unknown host (<DD_hostname>)'

Cause

Der Agent-Host verfügt über keinen Eintrag für das Data Domain-System in seiner lokalen Hostdatei. Daher kann der Hostname nicht in eine IP-Adresse aufgelöst werden, was dazu führt, dass die SNMP-Sitzungsinitialisierung fehlschlägt. 
 

Resolution

Fügen Sie die IP-Adresse und den Hostnamen des Data Domain-Systems zur Hostdatei auf dem Agent-Host hinzu.

Weitere Informationen zur Auflösung des SNMP-Hostnamens finden Sie in der Microsoft-Dokumentation (Erweiterungslink). SNMP verwendet Windows Internet Naming Service (WINS) oder die lokale Hostdatei, um Hostnamen aufzulösen. Wenn WINS nicht verfügbar ist, muss die Hostdatei die korrekten Zuordnungen enthalten.

Bewährte Vorgehensweise:
Verwenden Sie Hostnamen anstelle von IP-Adressen in SNMP-Managementanwendungen. Stellen Sie sicher, dass alle teilnehmenden Systeme genaue Hostname-zu-IP-Zuordnungen in ihren Hostdateien haben.

Nächste Schritte:
Wenn das Problem nach dem Aktualisieren der Hostdatei weiterhin besteht, wenden Sie sich an das Team des technischen Supports von Dell, um weitere Unterstützung zu erhalten. 

Affected Products

Data Domain, Data Protection Advisor

Products

Data Protection Suite Series, Integrated Data Protection Appliance Family
Article Properties
Article Number: 000168556
Article Type: Solution
Last Modified: 18 Nov 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.