NetWorker: vProxy FLR misslyckas med felmeddelandet "Det gick inte att logga in på Data Domain-tjänsten"

Summary: vProxy FLR misslyckas med felmeddelandet "Det gick inte att logga in på Data Domain-tjänsten"

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

NetWorker VMware Protection (NVP) FLR misslyckas och rapporterar "Det gick inte att logga in på Data Domain Service"

NetWorker Data Domain Systems-resurserna konfigureras med rätt användare på administratörsnivå för Data Domain:

Data Domain-hanteringsanvändare

Obs! Hanteringsanvändaren måste vara en användare på administratörsnivå på Data Domain, till exempel: sysadmin. Lösenordet måste vara korrekt. Kontrollera att du kan logga in på webbgränssnittet för Data Domain-hantering som sysadmin. Om du har loggat in korrekt uppdaterar du fältet "management password" för Data Domain i NetWorker för att säkerställa att rätt lösenord är angivet.

Loggarna för vProxy FLR-monteringssessionen visar "anslutning återställd av peer"

  • /opt/emc/vproxy/runtime/logs/recycle/vflrd/DATE/mount-SESSION-ID.log
2020-05-04T17:38:40Z INFO: [@(#) Build number: 117] Unmounting after mount failure: Unable to create NFS export at '[DD_FQDN]:/data/col1/[NW_FQDN]/FLR-[VM_NAME]-94f73769-7ddc-4a6b-a21d-742bdb4894f1': Unable to login while creating NFS export at '[DD_FQDN]:/data/col1/[NW_NAME]/FLR-[VM_NAME]-94f73769-7ddc-4a6b-a21d-742bdb4894f1': Failed to login to DataDomain service at 'https://[DD_NAME]:3009/rest/v1.0/auth': Post https://[DD_FQDN]:3009/rest/v1.0/auth: read tcp []->[]:3009: read: connection reset by peer

Ibland kan vProxy nå Data Domain, men inte dess ESXi-värd, vilket orsakar anslutningsproblem. The ESXi nc (netcat) kan användas för att verifiera portkommunikation med DD:

nc -zv DD_HOSTNAME PORT
 

Cause

En nätverkskomponent eller brandvägg förhindrar anslutningen, vilket resulterar i felmeddelandet "anslutning återställs av peer".

Resolution

Kontakta nätverks- eller brandväggsteamet angående anslutningsproblemet.

Följande utdata kan användas för att identifiera var problemet uppstår:

  1. Från vProxy använder du curl-kommandon för att kontrollera att du kan ansluta till portarna 22, 2049, 2052 och 3009 på DD:
curl -v DD_HOSTNAME:PORT
  1. Från vProxy kontrollerar du att vProxy kan upprätta SSL-anslutning med DD:
curl -kv https://DD_HOSTNAME:3009/rest/v1.0/trust
Obs! Utdata från det här kommandot förväntas returnera det självsignerade SSL-certifikat som används för att ansluta till Data Domain.
  1. Från vProxy-rotkonsolen , starta tcpdump:
Obs! Du kan inte SSH-logga direkt till vProxy som rot. Öppna en SSH-session och logga in som administratör. Bytet till rot med hjälp av sudo su -.

tcpdump -i any -s 0 -C 500 -w /tmp/`hostname`_`date -I`.pcap

  • -i anger gränssnitt, kan du använda vilket som helst eller ange ett namn på systemnätverksgränssnittet, till exempel eth0.
  • -s 0 Anger en fästlängd på 65535 (hela bildrutan hämtas).
  • -C 500 anger en filstorlek på 500 000 000 byte.
  • -w anger platsen för utdatafilen. Utdatafilen som visas genereras automatiskt med systemets värdnamn och ÅÅÅÅ-MM-DD som den kördes i. 
  1. Starta FLR-monteringen från NMC. När ett problem observeras stoppar du tcpdump (CTRL+C) och granska den tidsstämplade .pcap från katalogen /tmp för eventuella anslutningsproblem.
Obs! En .pcap-fil kan analyseras i Wireshark. TrådhajDen här hyperlänken tar dig till en webbplats utanför Dell Technologies. är ett verktyg från tredje part som används för att analysera paketinsamlingar. Kontakta nätverksadministratören om du vill ha hjälp med att granska paketinsamlingen. 
  1. Från ESXi-värdvärden vProxy som används för FLR (visas i VMware) kontrollerar du att ESXi-värden kan nå portarna 22, 2049, 2052, 3009 på DD.
nc -zv DD_HOSTNAME PORT

Additional Information

Affected Products

NetWorker

Products

NetWorker Family
Article Properties
Article Number: 000173057
Article Type: Solution
Last Modified: 14 Aug 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.