NetWorker: vProxy FLR не працює з помилкою "Не вдалося увійти в сервіс Data Domain"

Summary: vProxy FLR завершує роботу з помилкою "Не вдалося увійти в сервіс Data Domain"

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

NetWorker VMware Protection (NVP) FLR не працює, повідомляється про те, що «Не вдалося увійти в службу Data Domain Service»

Ресурси NetWorker Data Domain Systems налаштовані з правильним користувачем рівня "admin" для Data Domain:

Користувач з управління доменом даних

ПРИМІТКА. Користувач керування має бути користувачем рівня "admin" у домені даних, наприклад: sysadmin. Пароль має бути правильним. Переконайтеся, що ви можете увійти у веб-інтерфейс керування доменом даних як сисадмін. Якщо ви успішно увійшли в систему, оновіть поле «пароль управління» для домену даних в NetWorker, щоб переконатися, що встановлено правильний пароль.

У журналах сеансів монтування vProxy FLR відображається "з'єднання скинуто одноранговим вузлом"

  • /opt/emc/vproxy/runtime/logs/recycle/vflrd/DATE/mount-SESSION-ID.log
2020-05-04T17:38:40Z INFO: [@(#) Build number: 117] Unmounting after mount failure: Unable to create NFS export at '[DD_FQDN]:/data/col1/[NW_FQDN]/FLR-[VM_NAME]-94f73769-7ddc-4a6b-a21d-742bdb4894f1': Unable to login while creating NFS export at '[DD_FQDN]:/data/col1/[NW_NAME]/FLR-[VM_NAME]-94f73769-7ddc-4a6b-a21d-742bdb4894f1': Failed to login to DataDomain service at 'https://[DD_NAME]:3009/rest/v1.0/auth': Post https://[DD_FQDN]:3009/rest/v1.0/auth: read tcp []->[]:3009: read: connection reset by peer

Іноді vProxy може досягти домену даних, але його хост ESXi не може, що спричиняє проблеми з підключенням. Модель ESXi nc (netcat) можна використовувати для перевірки зв'язку порту з DD:

nc -zv DD_HOSTNAME PORT
 

Cause

Мережевий компонент або брандмауер перешкоджає підключенню, що призводить до повідомлення про помилку «З'єднання скинуто одноранговим вузлом».

Resolution

Зверніться до команди мережі або брандмауера щодо проблеми з підключенням.

Наведені нижче виходи можна використовувати для визначення місця виникнення проблеми:

  1. З vProxy використовуйте команди curl, щоб переконатися, що ви можете підключатися до портів 22, 2049, 2052 і 3009 на DD:
curl -v DD_HOSTNAME:PORT
  1. З vProxy переконайтеся, що vProxy може встановлювати SSL з'єднання з DD:
curl -kv https://DD_HOSTNAME:3009/rest/v1.0/trust
ПРИМІТКА. Очікується, що вихідні дані цієї команди повернуть самопідписаний сертифікат SSL, який використовується для з'єднання з доменом даних.
  1. У кореневій консолі vProxy запустіть tcpdump:
ПРИМІТКА. Ви не можете SSH безпосередньо до vProxy від імені root. Відкрийте сеанс SSH і увійдіть як адміністратор. Перехід на root за допомогою sudo su -.

tcpdump -i any -s 0 -C 500 -w /tmp/`hostname`_`date -I`.pcap

  • -i вказує інтерфейс, можна використовувати будь-який, або вказує ім'я інтерфейсу системної мережі, наприклад eth0.
  • -s 0 Вказує довжину знімка 65535 (захоплюється весь кадр).
  • -C 500 Параметр вказує розмір файлу 500 000 000 байт.
  • -w Параметр вказує місце розташування вихідного файлу. Показаний файл результату буде автоматично створено з іменем системного хосту та РРРР-ММ-ДД, на якому його було запущено. 
  1. З NMC ініціюйте кріплення FLR. Якщо ви помітите проблему, зупиніть tcpdump (CTRL+C) і перегляньте часову позначку .pcap файл з каталогу /tmp для будь-яких проблем з підключенням.
ПРИМІТКА. Файл .pcap можна проаналізувати в Wireshark. Дротяна акулаЦе гіперпосилання веде вас на веб-сайт за межами Dell Technologies. — це стороння утиліта, яка використовується для аналізу захоплень пакетів. Зверніться до адміністратора мережі за допомогою з перевіркою перехоплення пакета. 
  1. З хостингу ESXi vProxy, який використовується для FLR (показано в VMware), переконайтеся, що хост ESXi може досягати портів 22, 2049, 2052, 3009 на DD.
nc -zv DD_HOSTNAME PORT

Additional Information

Affected Products

NetWorker

Products

NetWorker Family
Article Properties
Article Number: 000173057
Article Type: Solution
Last Modified: 14 Aug 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.