Avamar: PDM이 권장 프록시를 로드할 때 "Login failed due to invalid credentials or vcenter"라는 메시지가 표시됨

Summary: Avamar: Proxy Deployment Manager가 권장 프록시를 로드할 때 "잘못된 자격 증명 또는 vCenter로 인해 로그인 실패"라는 메시지가 표시됨

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

권장 프록시를 확인하려고 하면 Avamar의 Proxy Deployment Manager가 다음 메시지를 보고합니다.

"잘못된 자격 증명 또는 vcenter로 인해 로그인 실패"
 
kA2f1000000L4tnCAC_3_0

Cause

VCS Connection Manager 로그 "/usr/local/avamar/var/log/vcs/connectionmanager.log"에 다음 오류가 표시됩니다.    
 
2017-06-05T02:03:22.971+0500 TRACE [cTaskExecutor-4][     handler.ConnectionHandler#    handleMessage]: [Leaving]
2017-06-05T02:03:22.971+0500 ERROR [cTaskExecutor-3][   model.ConnectionPoolManager#           logout]: Pool is not available.  Invalid ticket: ...a1a7522bfec3
2017-06-05T02:03:22.971+0500 DEBUG [cTaskExecutor-3][   model.ConnectionPoolManager#           logout]: 
TicketPools:
...50c79c741e9f: com.emc.avamar.vmware.connection.model.VSphereConnectionPool@62cf90d1
...a1019b98afac: com.emc.avamar.vmware.connection.model.VSphereConnectionPool@62cf90d1

In the VCS deploymanager log file /usr/local/avamar/var/log/vcs/deploymanager.log, the following is seen:    
 
7-07-13T16:12:45.466+0500 ERROR [cTaskExecutor-6][       impl.UserSessionService#            login]: Error communicating with connection manager
2017-07-13T16:12:45.466+0500 TRACE [cTaskExecutor-6][        handler.RequestHandler#    handleMessage]: LoginResponse [sessionId=null, success=false, reason=Login failed due to invalid credentials or vcenter, statusCode=401]
2017-07-13T16:12:46.601+0500 TRACE [cTaskExecutor-7][        handler.RequestHandler#    handleMessage]: LoginRequest [vcenter=xx.xx.xx.xx, port=443, user=avamar, locale=null]
2017-07-13T16:12:46.602+0500 TRACE [cTaskExecutor-7][       impl.UserSessionService#            login]: Login request for avamar@xx.xx.xx.xx:443
2017-07-13T16:17:46.602+0500 ERROR [cTaskExecutor-7][       impl.UserSessionService#            login]: Error communicating with connection manager


 

Resolution

절차:   
  1. Telnet 또는 curl을 사용하여 포트 443이 vCenter 호스트에 대해 열려 있는지(Avamar에서) 확인합니다.
필요한 데이터 포트에 대한 자세한 내용은 VMware 사용자 가이드(버전 106페이지 참조)를 참조하십시오. 7.3 수동)
 
curl -kv xx.xx.xx.xx:443

* About to connect() to xx.xx.xx.xx port 443 (#0)

*   Trying xx.xx.xx.xx... connected

* Connected to xx.xx.xx.xx (xx.xx.xx.xx) port 443 (#0)
 

  1. OS 루트 사용자로 Apache Tomcat을 재시작합니다
emwebapp.sh --stop
emwebapp.sh --start를 누른 다음
 


Proxy Deployment Manager가 더 이상 오류를 보고하지 않아야 합니다.

Affected Products

Avamar

Products

Avamar, Avamar Client for VMware
Article Properties
Article Number: 000175084
Article Type: Solution
Last Modified: 21 Nov 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.