Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products

Alienware Laptops with Killer Wireless: Cannot Connect to the Internet through LAN or Wireless

Summary: System may not connect to the Internet through the wireless card or LAN cable. Issue may appear after updating the wireless network driver.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

SLN300762_en_US__1iC_aw_alienhead_mr_v1 Description  

This issue affects only computers that are equipped with the Killer LAN E2400 and Killer WLAN 1535 adapters.


Supported Systems:

 
  Alienware 13 R2   Alienware 15 R2   Alienware 17 R3  
  Alienware 13 R3   Alienware 15 R3   Alienware 17 R4  

  1. Uninstall the Killer Network Manager Suite and the Killer Wireless Drivers.

    1. Right Click on the lower left corner of the screen.
    2. Click Programs and Features.
    3. Click Killer Network Manager Suite and click Uninstall.
    4. Follow the On-Screen instructions and repeat the same process for the Killer Wireless Drivers.
    5. Restart the computer once both applications have been removed.
    NOTE: If the programs above are not listed under Programs and features, continue to the next step.

  2. Download and Install the Killer Ethernet E2400 Driver.

    1. Use the SupportAssist application to update drivers for you, browse to the SupportAssist for PCs and tablets page for more information.
    2. See the How do I download and install a driver? section of Dell Knowledge base article Drivers and Downloads FAQs for information about manually updating drivers.
    3. See the Microsoft Knowledge Base article Windows Update: FAQ for information about how to get the latest version of Windows and updates.
    4. After installation of the E2400 driver, restart the computer.

  3. Download and Install the Killer Wireless-AC 1535 Driver.

    1. Use the SupportAssist application to update drivers for you, browse to the SupportAssist for PCs and tablets page for more information.
    2. See the How do I download and install a driver? section of Dell Knowledge base article Drivers and Downloads FAQs for information about manually updating drivers.
    3. See the Microsoft Knowledge Base article Windows Update: FAQ for information about how to get the latest version of Windows and updates.
    4. After installation of the Killer Wireless-AC 1535 Driver, restart the computer.
    5. Open the Killer Suite app, go to settings, and disable the "Advanced Stream Detect" option.
    6. Open the Device Manager.
    7. Go into Network Adapters.
    8. Open Killer Wireless-AC 1535.
    9. Go to the Advanced tab.
    10. Under Wireless Mode, choose ABGN mode.

    NOTES:
    • Ensure that the version on both drivers you are downloading are the latest available from Dell's website) using the tools that are listed.
    • When you want to update the drivers in the future, ensure to uninstall all previous versions of both LAN and wLAN drivers.
    • When installing new drivers, you must install the LAN driver before installing the wLAN driver.

Cause

SLN316295_en_US__1I_aw_2016logo_mr_v1

  SLN316295_en_US__2iC_aw_twitter_mr_v1   SLN316295_en_US__3iC_aw_youtube_mr_v1   SLN316295_en_US__4iC_aw_facebook_mr_v1   SLN316295_en_US__5iC_aw_alienhead_mr_v1

Resolution


Out of Warranty support Out of warranty? No problem. Browse to the Dell.com/support website and enter your Dell Service Tag and view our offers.

NOTE: Offers are only available for US, Canada, UK, France, Germany, China, and Japan personal computer customers. Server and Storage not applicable.

Affected Products

Alienware 13 R3, Alienware 13 R2, Alienware 15 R3, Alienware 15 R2, Alienware 17 R4, Alienware 17 R3, Alienware Aurora R5, Alienware Aurora R6
Article Properties
Article Number: 000178432
Article Type: Solution
Last Modified: 18 Jun 2021
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.