Dell Security Management-serveren kan ikke eksportere rapporterne
Summary: Denne artikel omhandler årsagen til og løsningen på, at Dell Security Management Server ikke eksporterede en administreret rapport med en generisk fejl i fjernkonsollen.
Symptoms
Berørte produkter:
- Dell Security Management Server
Berørte versioner:
- v10.x og tidligere
Påvirkede operativsystemer:
- Windows
På Dell Security Management Server er det muligt at generere og eksportere forskellige administrerede rapporter ved at gå til Rapportering -> Administrer rapporter:

Figur 1: (Kun på engelsk) Vælg administrerede rapporter
For at eksportere en rapport er det tilstrækkeligt at vælge Eksporter fil og vælge formatet Excel eller CSV:

Figur 2: (Kun på engelsk) Vælg filtype til eksport
Figur 3: (Kun på engelsk) Meddelelse om forbindelse afvist
Kontrol af Security Server Service-logfilerne i c:\Programmer\*** En fejl, der ligner den nedenfor, rapporteres på tidspunktet for fejlen:
2020-12-07 12:07:56,350 ERROR com.dell.ddps.webui.controllers.ReportController [qtp1551039242-71115] - Timeout in webservice controller java.lang.IllegalStateException: WRITER 2020-12-07 12:07:56,351 ERROR com.dell.ddps.webui.controllers.ReportController [qtp1551039242-71115] - ServiceException thrown in webservice controller com.dell.ddps.webui.controllers.BaseWebUiController$LocalizedServiceException: The service did not respond in a timely manner. 2020-12-07 12:07:56,352 WARN org.springframework.web.servlet.mvc.method.annotation.ExceptionHandlerExceptionResolver [qtp1551039242-71115] - Failed to invoke @ExceptionHandler method: public java.lang.Object com.dell.ddps.webui.controllers.BaseWebUiController.handleException(javax.servlet.http.HttpServletRequest,javax.servlet.http.HttpServletResponse,java.lang.Exception,java.util.Locale) java.lang.IllegalStateException: WRITER 2020-12-07 12:07:56,353 WARN org.eclipse.jetty.server.HttpChannel [qtp1551039242-71115] - /webui/exportToExcel javax.servlet.ServletException: org.springframework.web.util.NestedServletException: Request processing failed; nested exception is java.lang.IllegalStateException: WRITER
Cause
DoS-filteret (Denial of Service) afslutter serverforbindelsen efter 60 sekunder.
Resolution
Følg nedenstående trin for at øge DoS-filtertærsklen:
- Brug notesblok til at åbne webdefault.xml, der som standard er placeret i C:\Programmer\Dell\Enterprise Edition\Security Server\conf, og opdater timeouts for MaxRequestMs og maxIdleTrackerMs fra 60000 til 300000:

Figur 4: (Kun på engelsk) webdefault.xml
- Når værdierne er blevet ændret fra 60000 til 300000, skal du gemme filen og genstartesikkerhedsservertjenesten . Følg nedenstående trin for at genstarte Security Server Service:
- Højreklik på Start og vælg Kør:

Figur 5: (Kun på engelsk) Klik på Kør
- Skriv services.msc i dialogboksen Kør, og tryk på Enter, eller klik på OK:

Figur 6: (Kun på engelsk) Indtast services.msc
- Højreklik på Dell Security Server Service, og vælg Genstart:

Figur 7: (Kun på engelsk) Genstart tjenesten
For at kontakte support kan du bruge internationale supporttelefonnumre til Dell Data Security.
Gå til TechDirect for at oprette en anmodning om teknisk support online.
Hvis du vil have yderligere indsigt og ressourcer, skal du tilmelde dig Dell Security Community-forummet.