Dell Security Management Server Fails to Export the Reports

Summary: This article discusses the cause and the resolution of the Dell Security Management Server failing to export a managed report with a generic error in the Remote Console.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Affected Products:

  • Dell Security Management Server

Affected Versions:

  • v10.x and Earlier

Affected Operating Systems:

  • Windows

On the Dell Security Management Server, it is possible to generate and export different managed reports, by going to Reporting -> Manage Reports:

Manage Reports
Figure 1: (English Only) Choose Managed Reports

To export a report, it is sufficient to select Export File and choose the format Excel or CSV:

Export File
Figure 2: (English Only) Choose file type for export

Caution: Due to the size of the report and the number of endpoints, it is possible that while waiting for the report to be exported, after 60 seconds, the Dell Security Management Console will throw the error below and the export will fail: 
Connection Refused Error
Figure 3: (English Only) Connection Refused message

Checking the Security Server Service logs in c:\Program Files\*** an error similar to the one below is reported at the time of the failure:

2020-12-07 12:07:56,350 ERROR com.dell.ddps.webui.controllers.ReportController [qtp1551039242-71115] - Timeout in webservice controller java.lang.IllegalStateException: WRITER
2020-12-07 12:07:56,351 ERROR com.dell.ddps.webui.controllers.ReportController [qtp1551039242-71115] - ServiceException thrown in webservice controller com.dell.ddps.webui.controllers.BaseWebUiController$LocalizedServiceException: The service did not respond in a timely manner.
2020-12-07 12:07:56,352 WARN org.springframework.web.servlet.mvc.method.annotation.ExceptionHandlerExceptionResolver [qtp1551039242-71115] - Failed to invoke @ExceptionHandler method: public java.lang.Object com.dell.ddps.webui.controllers.BaseWebUiController.handleException(javax.servlet.http.HttpServletRequest,javax.servlet.http.HttpServletResponse,java.lang.Exception,java.util.Locale) java.lang.IllegalStateException: WRITER
2020-12-07 12:07:56,353 WARN org.eclipse.jetty.server.HttpChannel [qtp1551039242-71115] - /webui/exportToExcel javax.servlet.ServletException: org.springframework.web.util.NestedServletException: Request processing failed; nested exception is java.lang.IllegalStateException: WRITER

Cause

The Denial of Service (DoS) filter terminates the server connection after 60 seconds.

Resolution

To increase the DoS filter threshold, follow the below steps:

  1. Using notepad, open the webdefault.xml, located in C:\Program Files\Dell\Enterprise Edition\Security Server\conf by default, and update the MaxRequestMs and maxIdleTrackerMs timeouts from 60000 to 300000:

webdefault.xml
Figure 4: (English Only) webdefault.xml

  1. After the values have been changed from 60000 to 300000, save the file and restart the Security Server Service. To restart the Security Server Service, follow the steps below:
  2. Right click on Start and select Run:

run
Figure 5: (English Only) Click run

  1. In the Run dialog window type services.msc and press enter or click OK:

services.msc
Figure 6: (English Only) Type services.msc

  1. Right click on the Dell Security Server Service and select Restart:

Restart
Figure 7: (English Only) Restart service


To contact support, reference Dell Data Security International Support Phone Numbers.
Go to TechDirect to generate a technical support request online.
For additional insights and resources, join the Dell Security Community Forum.

Affected Products

Dell Encryption
Article Properties
Article Number: 000184829
Article Type: Solution
Last Modified: 04 Mar 2024
Version:  8
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