Dell Security Management Server non riesce a esportare i report
Summary: Questo articolo descrive la causa e la risoluzione del problema con cui Dell Security Management Server non esporta un report gestito con un errore generico nella Remote Console.
Symptoms
Prodotti interessati:
- Dell Security Management Server
Versioni interessate:
- v10.x e versioni precedenti
Sistemi operativi interessati:
- Windows
Su Dell Security Management Server, è possibile generare ed esportare diversi report gestiti accedendo a Reporting -> Manage Reports:

Figura 1. (solo in inglese) Scegliere Report gestiti
Per esportare un report è sufficiente selezionare Export File e scegliere il formato Excel o CSV:

Figura 2. (solo in inglese) Scegli il tipo di file per l'esportazione
Figura 3. (solo in inglese) Messaggio di connessione rifiutata
Controllo dei registri del servizio Security Server in c:\Program Files\*** al momento dell'errore viene segnalato un errore simile a quello riportato di seguito:
2020-12-07 12:07:56,350 ERROR com.dell.ddps.webui.controllers.ReportController [qtp1551039242-71115] - Timeout in webservice controller java.lang.IllegalStateException: WRITER 2020-12-07 12:07:56,351 ERROR com.dell.ddps.webui.controllers.ReportController [qtp1551039242-71115] - ServiceException thrown in webservice controller com.dell.ddps.webui.controllers.BaseWebUiController$LocalizedServiceException: The service did not respond in a timely manner. 2020-12-07 12:07:56,352 WARN org.springframework.web.servlet.mvc.method.annotation.ExceptionHandlerExceptionResolver [qtp1551039242-71115] - Failed to invoke @ExceptionHandler method: public java.lang.Object com.dell.ddps.webui.controllers.BaseWebUiController.handleException(javax.servlet.http.HttpServletRequest,javax.servlet.http.HttpServletResponse,java.lang.Exception,java.util.Locale) java.lang.IllegalStateException: WRITER 2020-12-07 12:07:56,353 WARN org.eclipse.jetty.server.HttpChannel [qtp1551039242-71115] - /webui/exportToExcel javax.servlet.ServletException: org.springframework.web.util.NestedServletException: Request processing failed; nested exception is java.lang.IllegalStateException: WRITER
Cause
Il filtro Denial of Service (DoS) interrompe la connessione al server dopo 60 secondi.
Resolution
Per aumentare la soglia del filtro DoS, attenersi alla seguente procedura:
- Utilizzando Blocco note, aprire il webdefault.xml, che si trova in C:\Program Files\Dell\Enterprise Edition\Security Server\conf per impostazione predefinita, e aggiornare i timeout di MaxRequestMs e maxIdleTrackerMs da 60000 a 300000:

Figura 4. (solo in inglese) webdefault.xml
- Dopo aver modificato i valori da 60000 a 300000, salvare il file e riavviare il servizio Security Server . Per riavviare il servizio Security Server, attenersi alla seguente procedura:
- Cliccare con il pulsante destro del mouse su Start e selezionare Esegui:

Figura 5. (solo in inglese) Cliccare su Esegui
- Nella finestra di dialogo Esegui, digitare services.msc e premere Invio o fare clic su OK:

Figura 6. Digitazione di services.msc (solo in inglese)
- Cliccare con il pulsante destro del mouse su Dell Security Server Service e selezionare Riavvia:

Figura 7. (solo in inglese) Riavviare il servizio
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