NetWorker: Odzyskiwanie systemu plików nie działa z błędem "File Index is missing"

Summary: Odzyskiwanie systemu plików nie działa z powodu błędu "File Index is missing Please contact the system administrator to recover or re-create the index".

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Podczas odzyskiwania poziomu plików klienta NetWorker z konsoli zarządzania NetWorker (NMC) zwracany jest błąd informujący o braku indeksu plików:
 
Komunikat o błędzie: Brak indeksu plików
Rysunek 1. Komunikat o błędzie: Brak indeksu plików.

Cause

Brak folderu indeksu plików klienta lub pusty:

Linux: /nsr/index/CLIENT-NAME
Windows: C:\Program Files\EMC NetWorker\nsr\index\CLIENT-NAME
 
Zrzut ekranu przedstawiający brakujący folder indeksu plików klienta
Rysunek 2. Zrzut ekranu przedstawiający brakujący folder indeksu plików klienta
 

Resolution

Na serwerze NetWorker otwórz monit administratora i uruchom jako root:
nsrck -L7 client-name
 
UWAGA: Nazwa klienta powinna być zgodna z nazwą klienta określoną na karcie Klienty konsoli zarządzania NetWorker. opcjonalnie nsraldb na kliencie NetWorker również to pokazuje. Na kliencie NetWorker otwórz monit administratora i uruchom jako root: 
nsradmin -p nsrexecd "nsrla"

Monitoruj dane wyjściowe polecenia nsrck pod kątem błędów. Po zakończeniu folder indeksu klienta powinien zostać ponownie zapełniony i można przeprowadzić przywracanie danych.

Additional Information

Nie dotyczy to odzyskiwania na poziomie plików maszyn wirtualnych VMware z kopią zapasową przy użyciu urządzenia vProxy NetWorker VMware Protection (NVP).

Affected Products

NetWorker Family
Article Properties
Article Number: 000200061
Article Type: Solution
Last Modified: 19 Mar 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.