PowerEdge : Échec de la conversion de l’évaluation de Windows Server avec la clé de produit de licence perpétuelle CSP
Summary: Cet article traite d’un problème dans lequel la conversion de Windows Server d’une version d’évaluation à une édition sous licence complète échoue. L’erreur renvoyée semble indiquer un problème avec la clé de produit fournie, mais la clé est réputée valide. ...
Symptoms
La conversion d’une évaluation de Windows Server en une édition entièrement sous licence échoue avec l’erreur suivante :
La clé de produit spécifiée n’a pas pu être validée. Vérifiez que la clé de produit spécifiée est valide et qu’elle correspond à l’édition cible.
La clé de produit fournie est associée à une licence Windows Server perpétuelle. Ces licences sont achetées via le programme Cloud Solution Provider (CSP) et les clés sont fournies par Microsoft 365 Admin Center.
Cause
La cause exacte est inconnue, mais ce comportement a été observé plusieurs fois lorsqu’une clé de produit CSP est utilisée pour la conversion.
Resolution
Pour contourner cette erreur, fournissez une clé KMS (Key Management System) lors de la conversion, puis remplacez la clé par la clé appropriée par la suite.
Les clés KMS, également connues sous le nom de clés de licence en volume génériques (GVLK), sont publiées par Microsoft ici : https://learn.microsoft.com/en-us/windows-server/get-started/kms-client-activation-keys
Les commandes suivantes indiquent la clé KMS spécifique à utiliser pour chaque version et édition du système d’exploitation (OS) :
Windows Server 2019 Standard
dism /online /set-edition:ServerStandard /productkey:N69G4-B89J2-4G8F4-WWYCC-J464C /accepteula
Windows Server 2019 Datacenter
dism /online /set-edition:ServerDatacenter /productkey:WMDGN-G9PQG-XVVXX-R3X43-63DFG /accepteula
Windows Server 2022 Standard
dism /online /set-edition:ServerStandard /productkey:VDYBN-27WPP-V4HQT-9VMD4-VMK7H /accepteula
Windows Server 2022 Datacenter
dism /online /set-edition:ServerDatacenter /productkey:WX4NM-KYWYW-QJJR4-XV3QB-6VM33 /accepteula
Windows Server 2025 Standard
dism /online /set-edition:ServerStandard /productkey:TVRH6-WHNXV-R9WG3-9XRFY-MY832 /accepteula
Windows Server 2025 Datacenter
dism /online /set-edition:ServerDatacenter /productkey:D764K-2NDRG-47T6Q-P8T8W-YP6DF /accepteula
Une fois la commande terminée, un redémarrage est requis. Après le redémarrage, le système d’exploitation ne sera plus considéré comme une évaluation. Toutefois, la clé KMS ne peut pas activer le système d’exploitation avec succès si un serveur KMS n’est pas en place dans l’environnement. Si aucun serveur KMS n’est utilisé, la clé doit être modifiée à l’aide des commandes suivantes : (Remplacez les X dans la deuxième commande par la clé de produit CSP.)
slmgr /upk slmgr /ipk XXXXX-XXXXX-XXXXX-XXXXX-XXXXX
Le système d’exploitation doit s’activer automatiquement peu de temps après l’exécution de la deuxième commande. L’activation peut être forcée à l’aide de la commande slmgr /ato mais ce n’est généralement pas nécessaire.
Regardez cette vidéo publiée :
Clé de licence CSP non valide
Durée : 00:04:30 (hh :mm :ss)
Lorsqu’ils sont disponibles, les paramètres de langue des sous-titres peuvent être choisis à l’aide de l’icône CC de ce lecteur vidéo.