Dell Pro Keyboard and Mouse KM5221W Does Not Work Intermittently on Inspiron AIO, Dell AIO EC, or XPS 8950 Desktop
Summary: Learn about a problem with the Dell Pro Keyboard and Mouse KM5221W when using on some Inspiron AIO, Dell AIO EC, and XPS desktops.
Symptoms
Dell Pro Keyboard and Mouse KM5221W may intermittently exhibit issues. The following symptoms may occur when the device is connected to the USB 3.0 ports on the Inspiron AIO, Dell AIO EC, or XPS 8950 desktop:
- Losing the connection
- Moving slowly
- Cursor not responding
- Keyboard not working
Affected Platforms:
- Dell 24 All-in-One EC24250
- Dell 27 All-in-One EC27250
- Inspiron 24 5410 All-in-One
- Inspiron 24 5411 All-in-One
- Inspiron 24 5415 All-in-One
- Inspiron 24 5430 All-in-One
- Inspiron 27 7710 All-in-One
- Inspiron 27 7730 All-in-One
- XPS 8950
Cause
This is an industry-wide behavior that occurs when a wireless mouse/keyboard receiver dongle is at a close distance to a USB 3.0 port, cable, or device. The 2.4GHz ISM band is a widely used unlicensed radio frequency band for devices such as wireless routers, and wireless mouses or keyboards. USB 3.0 can operate in the 2.4GHz~2.5GHz range, and the noise that is emitted can disrupt nearby transmitters. If the wireless mouse/keyboard receiver dongle is placed near a USB 3.0 radiation channel, it can pick up broadband noise. This noise can limit the sensitivity or receptiveness of the wireless receiver. Also, a close-range WiFi router may add a coupling effect. This effect can further strengthen the interference to the wireless mouse/keyboard receiver dongle.
Resolution
Perform one of the following steps to resolve the issue:
- Move the wireless mouse/keyboard receiver dongle away from the USB 3.0 ports that are in use.
- Use a USB extension cable for the wireless mouse/keyboard receiver dongle and place it away from the USB 3.0 device and WiFi router.
- An example of the USB extension cable can be found from the following dell site: USB Extension cable.
- Move Wi-Fi router away from the computer.