Summary:
Older models of PowerEdge servers may encounter a browser prompt that the iDRAC default SSL web-server certificate has expired. Access to the iDRAC UI is not affected but may affect
customers with higher security environments.
...
Please select a product to check article relevancy
This article applies to This article does not apply toThis article is not tied to any specific product.Not all product versions are identified in this article.
Access iDRAC web-server UI may show the following prompt:
Customers may still access the iDRAC web interface by choosing "Continue to this website."
Cause
The default iDRAC certificate validity period has expired, and you can go to the following page in the iDRAC7 or iDRAC8 verify it:
Figure 1: iDRAC settings > Network > SSL
Note:
For the iDRAC6 go to: "iDRAC Settings" > "Network/Security" > "SSL"
For the iDRAC8, go to: "iDRAC settings" > "Network" > "SSL" (as seen in figure 1)
Resolution
Updating iDRAC firmware and resetting iDRAC to factory default might not resolve the issue.
There is no option available in the web-server UI to reset or renew the certificate.
In those cases, the only option available is using CLI. You can use telnet or SSH or racadm tools to do this. See this manual page for details.
For iDRAC9 and custom certificates, look at the additional information at the end of this article.
Here is the specific command to renew the certificate:
sslresetcfg
Description
Restores the web-server certificate to factory default and restarts web-server. The certificate takes effect 30 seconds after the command is entered.
To run this subcommand, you must have the Configure iDRAC privilege.
Synopsis
racadm sslresetcfg
Input
N/A
Example
racadm sslresetcfg
Certificate generated successfully and webserver restarted.