PowerScale: S3-Objekt- und Datenzeitstempel stimmen zwischen PowerScale OneFS und dem S3-Browser nicht überein

Summary: Der im S3-Browser angezeigte Zeitstempel des AWS S3-Objekts und Daten-Buckets ist standardmäßig immer GMT-Zeitzone. Die Datei in der Isilon-Bucket-Pfadliste in der CIFS-Freigabe zeigt die richtige lokale Zeitzone an. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Nicht übereinstimmender Zeitstempel des S3-Objekts mit PowerScale OneFS

Beobachtung:
Laden Sie eine Datei hoch, z. B. s3browser-10-8-1.zip in den Bucket s3demo-bk01 unter test/test01/

PowerScale OneFS:
Der Zeitstempel ist korrekt: 
isi9x-1# ls -la
total 12734
drwxrwxrwx     2 s3demo  Isilon Users       38 Mar 28 09:55 .
drwxrwxrwx     3 s3demo  Isilon Users       79 Mar 28 09:55 ..
-rwx------ +   1 s3demo  Isilon Users  8521023 Mar 28 09:55 s3browser-10-8-1.zip
isi9x-1#

Korrekter Zeitstempel der Clientdatei
Abbildung 1: Korrekter Clientdatei-Zeitstempel


S3-Browser oder AWS S3-CLI:
Der Zeitstempel ist nicht korrekt.
PS C:\Users\Administrator> aws s3 ls s3://s3demo-bk01/test/test01/ --endpoint-url http://192.168.1.41:9020
2023-03-28 17:55:50    8521023 s3browser-10-8-1.zip

Falscher Zeitstempel der Clientdatei
Abbildung 2: Falscher Zeitstempel


der Clientdatei-PCAPsanzeigen:
LastModified:  2023-03-28T09:55:50.000Z
Dies gibt die GMT-Zeit an, was falsch ist.
 

Cause

Die Nichtübereinstimmung des Zeitstempels ist auf ein PowerScale OneFS-Codeproblem zurückzuführen. Derzeit verwendet der Code nur GMT.

Resolution

Das PowerScale-Engineering-Team arbeitet an einer Codekorrektur, die voraussichtlich in einer zukünftigen PowerScale OneFS-Version und einem zukünftigen Patch veröffentlicht wird.

Additional Information

Affected Products

PowerScale OneFS
Article Properties
Article Number: 000211774
Article Type: Solution
Last Modified: 08 Nov 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.