RecoverPoint für virtuelle Maschinen: Nutzerdefiniertes Mehrkettenzertifikat führt dazu, dass Aktualisierungen des Truststore fehlschlagen

Summary: Bei Verwendung eines nutzerdefinierten Zertifikats (nicht des Standardzertifikats oder eines selbstsignierten) Zertifikats wird eine Änderung des MTU-Werts auf einer RecoverPoint Appliance (RPA) NICHT auf andere Appliances übertragen. ...

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Symptoms

Suchen Sie nach den folgenden Fehlern: "addCertificateAuthority" In installationLogs/server.log:

at com.sun.xml.ws.client.sei.SEIStub.invoke(SEIStub.java:131) ~[jaxws-rt-2.3.3.jar:2.3.3] at com.sun.proxy.$Proxy560.addCertificateAuthority(Unknown Source) ~[?:?] 
at com.kashya.installation.server.commands.global.AddCertificateAuthorityWorker.callWebServiceInternal(AddCertificateAuthorityWorker.java:20) ~[classes/:?] 
at com.kashya.installation.server.infocollect.ClientWorker.execute(ClientWorker.java:220) ~[classes/:?]

Cause

Bei einem nutzerdefinierten Zertifikat schlägt eine Zertifikataktualisierung auf Truststore fehl.
Aufgrund von MTU-Nichtübereinstimmungen kommt es zu Kommunikationsfehlern.

Resolution

Problemumgehung:
Es gibt drei mögliche Problemumgehungen:

Problemumgehung #1:
Verwenden Sie ein selbstsigniertes Zertifikat anstelle eines benutzerdefinierten Zertifikats. Details finden Sie im RecoverPoint for Virtual Machines – Sicherheitskonfigurationsleitfaden.

  • Fügen Sie das vCenter-Zertifikat zur RecoverPoint-Seite hinzu:
    1. Fügen Sie das neue VC-Zertifikat im Base64-Format (nur CA-Zertifikat) manuell unter Vertrauenswürdiger Speicher der RPA hinzu.
    2. Loggen Sie sich in das Admin-Menü ein.
    3. Gehen Sie zu Optionen.
[2] Setup > [8] Advanced options > [2] Security options > [2] Certificates management > [2] Truststore management > [2] Add trusted certificate

​​​​​

  1. Fügen Sie das CA-Zertifikat zum vertrauenswürdigen Speicher von RPA hinzu.
    Sie müssen das Zertifikat in einer lesbaren Ansicht öffnen und das gesamte Zertifikat kopieren, einschließlich:
    -----BEGIN CERTIFICATE REQUEST-----
    To
    -----END CERTIFICATE REQUEST-----
    Fügen Sie es in PuTTY ein, fügen Sie dann ein # in eine neue Zeile ein und drücken Sie die Eingabetaste.
  2. Führen Sie den Befehl über die RPA-System-CLI aus.
update_vcenter_server_registration -f



Workaround #2:
Verwenden Sie vorübergehend das Standardzertifikat oder ein selbstsigniertes Zertifikat mithilfe des folgenden Verfahrens, um die MTU-Größen zu aktualisieren. Nachdem Sie bestätigt haben, dass die MTU-Änderung auf alle RPAs übertragen wurde, installieren Sie das nutzerdefinierte Zertifikat neu. Im Folgenden sind die Schritte zum Aktualisieren des Webzertifikats und der MTU-Konfiguration aufgeführt:

A. Aktualisieren des Zertifikats

  1. Erstellen Sie ein Kundenzertifikat:
Openssl req -newkey rsa:2048 -x509 -sha256 -days 365 -nodes -out certificate.pem -keyout privatekey.pem
  1. Ersetzen Sie das RPA-Webzertifikat durch ein neu erstelltes.

Verwenden Sie einen SSH-Client, um sich bei der vRPA Boxmgmt-CLI als Nutzer = admin anzumelden. Wählen Sie im Hauptmenü Folgendes aus:

Setup > Advanced Options > Security Options > Certificates Management > Keystore Management > Change Web Server Certificate.
  1.  Webzertifikat zum Truststore hinzufügen.

Verwenden Sie einen SSH-Client, um sich bei der vRPA Boxmgmt-CLI als Nutzer = admin anzumelden. Wählen Sie im Hauptmenü Folgendes aus:

Setup > Advanced Options > Security Options > Certificates Management > Truststore Management > Add trusted certificate
  1. Starten Sie den Tomcat-Service neu auf RPA - systemctl restart tomcat9

B. Aktualisieren von MTU-Werten

  1.  Greifen Sie mit Admin auf die SC RPA zu und ändern Sie den MTU-Wert in etwas anderes als die aktuelle MTU:
[2] Setup --> [1] Modify Settings --> [3] MTU configuration --> [2] configure MTU values

 

  1. Öffnen Sie eine neue CLI-Sitzung auf der zweiten RPA und vergewissern Sie sich, dass die MTU geändert wurde (wenn bereits eine vorhandene Sitzung zur zweiten RPA geöffnet ist, spiegelt dies die MTU-Änderung nicht wider, eine neue Sitzung ist erforderlich)

Problemumgehung #3:

Behalten Sie das nutzerdefinierte Zertifikat bei und aktualisieren Sie die MTU bei jeder RPA manuell.

Das detaillierte Verfahren für Workaround #3 ist wie folgt.

ssh admin@<RPA IP>

Main Menu **
[1] Installation
[2] Setup
[3] Diagnostics
[4] Cluster operations
[5] Shutdown/Reboot operations
[6] System management CLI
[Q] Quit


Ändern Sie die MTU-Konfiguration:

[2] Setup --> [1] Modify Settings --> [3] MTU configuration --> [2] Configure MTU values

Der Nutzer kann die MTU für jede Verbindung in seiner Netzwerkkonfiguration separat festlegen.
Eine typische Konfiguration verfügt über einen separaten Link für jedes LAN, WAN, Daten – aber jede Konfiguration kann mehr oder weniger Links haben.
Ändern Sie für jede Verbindung einzeln die MTU-Einstellung auf den gewünschten Wert (in der Regel 1500 oder 9000).
Nach dem Festlegen eines Wertes werden alle Werte gedruckt (LAN, WAN, Daten), dann wird der Benutzer aufgefordert, die Anwendung der Änderung zu bestätigen.
Wenn alle Werte korrekt eingestellt sind, geben Sie "Q" ein, um dieses Menü zu verlassen.
Es ist kein Neustart erforderlich, damit die neuen Einstellungen wirksam werden.

Wiederholen Sie dies für jede RPA im System. Stellen Sie sicher, dass dieselben Werte auf allen RPAs verwendet werden.


Auflösung:
Die technische Abteilung von Dell Technologies untersucht das Problem. Es wird noch an einer dauerhaften Lösung gearbeitet. Wenden Sie sich an das Dell Technologies Customer Support Center oder Ihren Servicemitarbeiter, um Unterstützung zu erhalten, und verweisen Sie auf diese Lösungs-ID.
 

Affected Products

RecoverPoint for Virtual Machines
Article Properties
Article Number: 000214843
Article Type: Solution
Last Modified: 07 Jan 2026
Version:  4
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