Avamar: Backup Fails with Status "No Data" Due to Incorrect Dataset Usage
Summary: Despite a dataset properly configured to use a given Plugin and Group policy configured to use that dataset, the backup started ends up using another dataset. (the configured dataset is being overridden) ...
Symptoms
-- Existing client:
admin@Lab-AVE:~/>: mccli client show --recursive |grep w11d15 clientname.some.company.com /clients Normal
-- Group properly configured to use specific dataset:
admin@Lab-AVE:~/>: mccli group show --name=/clients/Backup_Bol_Weekly |egrep "Attrib|---|Name|Type|Dataset"
Attribute Value
------------------------ -----------------------
Name Backup_Bol_Weekly
Type Normal
Dataset /Backup_Bol <--<-- Chosen dataset
-- Dataset configured to use specific Plugin:
admin@Lab-AVE:~/>: mccli dataset show --name=/Backup_Bol |egrep "Value|Name|ID" |sort -u Attribute Value ID 1684319635113 <--<-- Dataset ID number Name Backup_Bol Windows File System Target ID 3001 <--<-- Plugin in use on this dataset
-- Dataset being used instead (on this particular example), when the backup is started:
admin@Lab-AVE:~/>: mccli dataset show --name=/BkpBol_VSS_Only |egrep "Value|Name|ID" |sort -u Attribute Value ID 1693415871568 <--<-- Dataset ID number Name BkpBol_VSS_Only Windows VSS Target ID 3015 <--<-- Plugin in use on this dataset
-- Backup in progress, using the "wrong dataset"
(reduced command output to show the group, Plug-in, and dataset information since that info is in the far-right portion of the complete output)
- Same information can be seen in the Activity window in the AUI or Administration GUI:
admin@Lab-AVE:~/>: mccli activity show --name=/clients/clientname.some.company.com --verbose
0,23000,CLI command completed successfully.
Status Start Time Client Domain Group Plug-In Dataset
-------------- -------------------- ---------------------------- -------- -------------------------- ----------- ----------------
Waiting-Client 2023-08-30 15:26 BRT clientname.some.company.com /clients /clients/Backup_Bol_Weekly Windows VSS /BkpBol_VSS_Only <--<--
-- The backup started may end up with the status "No Data"
Cause
-- The option "Override dataset" is enabled.
-- Option is seen under "Backup Policy" in the Avamar AUI
-- While in the Avamar Administration UI the same option is under "Edit Client"
Review a similar issue found in KB: Avamar: Backup Fails with No Data Status - Unable to Determine Plugin Version
-- Example of a backup client with the override dataset enabled
(this is the root cause for the "wrong dataset" in use despite of group and dataset properly configured - dataset applied in the override lists its ID number only, not the dataset name):
admin@Lab-AVE:~/>: mccli client show --name=/clients/clientname.some.company.com |egrep "Value|---|Fully|Group" |head -5 Attribute Value ------------------------ ------------------------------------------------------------- Fully Qualified Name /clients/clientname.some.company.com Override Group Retention No Member of Group /clients/Backup_Bol_Weekly (Override Dataset: 1693415871568) <--
-- Example of a backup client with the override dataset disabled (the expected result of this article):
admin@Lab-AVE:~/>: mccli client show --name=/clients/clientname.some.company.com |egrep "Value|---|Fully|Group" |head -5
Attribute Value
------------------------ ------------------------------------------------------
Fully Qualified Name /clients/clientname.some.company.com
Override Group Retention No
Member of Group /clients/Backup_Bol_WeeklyResolution
How to Enable or Disable Override Dataset in Avamar.
Option 1: Avamar AUI
-
Navigate to Backup Policy:
- Go to Backup Policy in the Avamar AUI.
- Select the domain where the Backup Policy resides.
-
Edit the Backup Policy:
- Click the Backup Policy that you want to modify.
- Click EDIT.
-
Proceed to Summary:
- Click NEXT on each screen until you reach the Summary page.
- On the bottom-right corner, the button changes from NEXT to FINISH.
-
Set Override Dataset:
- Scroll to the bottom of the Summary page.
- Under Override Dataset, choose:
- Blank (to disable override), or
- The wanted dataset (to enable override).
-
Save Changes:
- Click FINISH.
Option 2: Avamar Administration UI
-
Navigate to Policy:
- Go to Policy in the Avamar Administration UI.
- Select Clients.
-
Select and Edit Client:
- Choose the client that you want to modify.
- Click Edit.
-
Go to Groups Tab:
- Open the Groups tab.
-
Set Override Dataset:
- Under Override Dataset, choose:
- Blank (to disable override), or
- The wanted dataset (to enable override).
- Under Override Dataset, choose: