Avamar: VSS 플러그인 백업 실행 중 속도 저하 문제 해결 지침

Summary: 이 문서에서는 불량 VSS(Volume Shadow Copy Service) 플러그인 백업 성능을 격리하기 위한 지침을 제공합니다. 느린 VSS 플러그인 및 Diskshadow 스냅샷은 Microsoft 드라이버 검증 프로그램 때문일 수 있습니다. Diskshadow 스냅샷은 빠를 수 있지만 Avamar VSS 플러그인 백업은 여전히 느립니다. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

VSS 플러그인 백업이 느리거나 두 VSS 플러그인 백업을 모두 실행하고 Diskshadow를 사용하여 이러한 중요 볼륨의 스냅샷을 생성하면 성능이 저하되었습니다. 

Cause

첫 번째 시나리오에서는 중요한 C:\ 드라이브에 있는 하위 폴더의 내용으로 인해 VSS 플러그인 백업 성능이 저하되어 전반적인 백업 효율성에 영향을 미쳤습니다.

케이스 1:  Windows 업데이트 기록에 대한 다음 폴더 콘텐츠로 인해 Avamar VSS 작업이 느려졌습니다.

c:\Windows\servicing\LCU\Package_for_RollupFix~31bf3856ad364e35~amd64~~20348.3328.1.7
c:\Windows\servicing\LCU\Package_for_RollupFix~31bf3856ad364e35~amd64~~20348.3207.1.6

DISM(배포 이미지 서비스 및 관리) 및 디스크 정리 유틸리티를 사용하여 지침에 따라 폴더 정리를 시작합니다.

https://learn.microsoft.com/en-us/answers/questions/2191628/winsxs-occupying-more-space [learn.microsoft.com(External Link) 
 

폴더 정리 및 제외 후 이전에 거의 2시간 30분이 걸렸던 VSS 백업이 이제 35-40분 내에 완료됩니다.

 

사례 #2: "c:\Windows\System32\spool\PRINTERS\*"의 폴더 내용으로 인해 VSS 백업 실행 속도가 느려졌습니다. 

해결책은 다음 폴더 항목에 대한 데이터 세트 제외를 추가하는 것이었습니다. 

--exclude=c:\Windows\System32\spool\PRINTERS\
--exclude=c:\Windows\System32\spool\PRINTERS*.tmp

 

사례 #3: "C:\users*\appdata\*"의 폴더 콘텐츠로 인해 Avamar VSS 백업 속도가 느려집니다. 

Exclude "AppData\Local", "AppData\LocalLow" and " AppData\Roaming" directories from VSS backups. 

위 폴더를 제외해도 다음 Microsoft 지침에 따라 VSS 백업의 무결성에 영향을 미치지 않습니다.

https://learn.microsoft.com/en-us/windows/apps/design/app-settings/store-and-retrieve-app-data (외부 링크)  

 

사례 #4: 이 경우 Avamar VSS 백업 또는 Diskshadow 유틸리티를 사용하여 중요 볼륨의 스냅샷을 생성하는 속도가 느려졌습니다. 근본 원인을 파악하려면 다음 명령을 사용하여 VSS 성능 추적을 활성화합니다(DOS admin 명령 프롬프트 사용).

i) logman create trace vss_trace -ow -o %temp%\%computername%_vss_trace.etl -p {9138500E-3648-4EDB-AA4C-859E9F7B7C38} 0xffffffffffffffff 0xff -nb 16 16 -bs 1024 -mode Circular -f bincirc -max 4096 –ets
ii) logman create counter PerfLog-1s -o "%temp%\%computername%_PerfLog-1.blg" -f bincirc -v mmddhhmm -max 300 -c "\LogicalDisk(*)\*" "\Memory\*" "\.NET CLR Memory(*)\*" "\Cache\*" "\Network Interface(*)\*" "\Netlogon(*)\*" "\Paging File(*)\*" "\PhysicalDisk(*)\*" "\Processor(*)\*" "\Processor Information(*)\*" "\Process(*)\*" "\Redirector\*" "\Server\*" "\System\*" "\Server Work Queues(*)\*" "\Terminal Services\*" -si 00:00:01
iii) logman start Perflog-1s

iv) Now START THE VSS backup USING DISKSHADOW or Avamar VSS Plugin

v) stop the trace once backup completed with the following elevated commands:
 
logman stop vss_trace -ets
logman stop Perflog-1s
logman delete Perflog-1s

캡처된 추적 로그는 거의 루프에서 "GetRootAndLogicalPrefixPaths" 함수의 연속 실행을 나타냅니다.


또한 추적에서는 모든 드라이버에서 사용하도록 설정된 드라이버 검증 도구가 범인이고 작업 속도를 늦추는 것을 보여 줍니다. 드라이버 검증 도구의 영향에 대한 자세한 내용은 https://learn.microsoft.com/en-us/windows-hardware/drivers/devtest/driver-verifier
(외부 링크)를 참조하십시오.

Resolution

케이스 1: c:\Windows\servicing\LCU 폴더의 작은 Windows 업데이트 파일로 인해 근본 원인이 확인되었습니다.

c:\Windows\servicing\LCU\Package_for_RollupFix~31bf3856ad364e35~amd64~~20348.3328.1.7
c:\Windows\servicing\LCU\Package_for_RollupFix~31bf3856ad364e35~amd64~~20348.3207.1.6

해결 방법은 DISM/"디스크 정리 유틸리티를 시작하여 중복 항목을 제거하고 도움이 되지 않는 경우 해결하는 것입니다. 
데이터 세트에서 이러한 하위 폴더의 명시적 제외를 추가합니다.

 

케이스 2: "c:\Windows\System32\spool\PRINTERS*.tmp"
의 .tmp 파일로 인해 근본 원인이 확인되었습니다. 해결 방법은 데이터 세트에 제외를 추가하여 VSS 백업에서 이러한 파일을 제외하는 것입니다.

--exclude=c:\Windows\System32\spool\PRINTERS*.tmp

 

사례 #3: "C:\users*\appdata\*"의 3개의 하위 폴더 항목으로 인해 근본 원인이 확인되었습니다. 하위 폴더의 파일에는 BMR(Bare Metal Recovery) 복구에 필요하지 않은 것으로 간주되는 사용자별 애플리케이션 데이터가 저장됩니다. 이 문제를  해결하려면 이 폴더와 세 개의 하위 폴더에 대한 전역 수준의 데이터 세트에서 제외를 추가합니다.

"C:\users*\appdata\*"

 

사례 #4: 해결 방법은 드라이버 검증 도구 실행을 비활성화하는 것이었고 VSS 백업은 10시간 이상 걸리지 않고 15분 내에 완료되었습니다. 또한 Diskshadow 스냅샷은 변경되기 전에 25분 이상 걸리지 않고 몇 초밖에 걸리지 않았습니다.

Article Properties
Article Number: 000222018
Article Type: Solution
Last Modified: 14 Nov 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.