PowerStore: Metro Volume polarization fails if the witness service is not restarted after java update
Summary: After a java update on the Witness server, polarization of Metro Volumes can fail if the witness service has not been restarted.
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Symptoms
Metro Volumes can fail to polarize on both PowerStore clusters if Witness is configured and java has been updated without a service restart.
This affects the Witness service version 1.0.0.
This affects the Witness service version 1.0.0.
Cause
The Witness service installed on an independent server uses Java 11. Certain system variables are only read during service startup.
If the service is not restarted, polarization requests for Metro Volumes can fail. This results in the Metro Volumes going into System Demoted state (offline) on both PowerStore Clusters
If the service is not restarted, polarization requests for Metro Volumes can fail. This results in the Metro Volumes going into System Demoted state (offline) on both PowerStore Clusters
Resolution
The dell-witness-service will automatically restart after a java upgrade in a future release.
After performing java or OS updates on the Witness server, restart the witness service:
sudo systemctl restart dell-witness-service
To verify if java has been updated since the last witness service start, compare the installed java version with the execution path of the witness service.
In this example, java 11.0.23 is installed, and witness has been re-started on this version:
If the Metro Volumes are down on both the preferred and non-preferred PowerStore clusters, manually promote the Metro Volumes on one of the two Clusters.
Contact Dell Technical Support for additional guidance if needed.
After performing java or OS updates on the Witness server, restart the witness service:
sudo systemctl restart dell-witness-service
To verify if java has been updated since the last witness service start, compare the installed java version with the execution path of the witness service.
In this example, java 11.0.23 is installed, and witness has been re-started on this version:
[witness@test-pwrstr-witness01 ~]$ java -version openjdk version "11.0.23" 2024-04-16 LTS OpenJDK Runtime Environment (Red_Hat-11.0.23.0.9-2) (build 11.0.23+9-LTS) OpenJDK 64-Bit Server VM (Red_Hat-11.0.23.0.9-2) (build 11.0.23+9-LTS, mixed mode, sharing) [witness@test-pwrstr-witness01 ~]$ ps -eaf | grep witness-service-fat | grep -v grep root 1126 922 0 May10 ? 00:00:00 sudo /usr/lib/jvm/java-11-openjdk-11.0.23.0.9-3.el8.x86_64/bin/java -Xmx512m -Dsystem.ip= -jar /opt/dell-witness-service/lib/witness-service-fat.jar root 1673 1126 0 May10 ? 01:20:16 /usr/lib/jvm/java-11-openjdk-11.0.23.0.9-3.el8.x86_64/bin/java -Xmx512m -Dsystem.ip= -jar /opt/dell-witness-service/lib/witness-service-fat.jarIf the running service references an older java version, restart the witness service.
If the Metro Volumes are down on both the preferred and non-preferred PowerStore clusters, manually promote the Metro Volumes on one of the two Clusters.
WARNING: Promote can result in data corruption if the remote system is online and serving I/O. If the connection between the current system and the remote system is down, verify that the remote system is no longer online.
Contact Dell Technical Support for additional guidance if needed.
Affected Products
PowerStore 1000T, PowerStore 1200T, PowerStore 3000T, PowerStore 3200Q, PowerStore 3200T, PowerStore 5000T, PowerStore 500T, PowerStore 5200T, PowerStore 7000T, PowerStore 9000TProducts
PowerStore 9200TArticle Properties
Article Number: 000225384
Article Type: Solution
Last Modified: 28 May 2024
Version: 2
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