PowerStore: Tilstandskontrol før opgradering (PUHC) og systemtilstandskontrol (SHC) for at registrere, om der findes en diskenhedsgruppe uden medlemmer
Summary: Disse kontroller er designet til at finde eventuelle volumengrupper uden medlemmer, eller hvis der findes diskenheder med interne attributter, der giver anledning til bekymring. PUHC-kontrollen (empty_vg_no_members) stopper opgraderingen til PowerStoreOS 4.0.x, hvis der opstår dette problem. SHC-kontrollen (invalid_vg_uuid_check) mislykkes, hvis dette problem findes på en klynge, der kører PowerStoreOS 4.0.x. ...
Symptoms
PowerStore Pre-Upgrade Health Check (PUHC) og System Health Check (SHC) registrerer muligvis dette problem, når de køres på følgende PowerStoreOS-versioner:
- PowerStoreOS 3.x
- PowerStoreOS 4.x
Scenarie 1:
Når du kører Pre-Upgrade Health Check (PUHC), observeres følgende meddelelse muligvis før en opgradering til PowerStoreOS 4.0.x:
- Pre-Upgrade Health Check (PUHC) kan returnere følgende meddelelse:
Exists volume groups with no members. Please delete those volume groups and then add them back after NDU. KB # 000238653 (empty_vg_no_members).
- Denne PUHC-kontrol mislykkes, hvis der findes en diskenhedsgruppe, som har nul (0) medlemsvolumener
- Læs afsnittet Løsning i denne Knowledge Base-artikel for at se, om der skal foretages korrigerende handlinger.
- En ikke-forstyrrende softwareopgradering (NDU) vil ikke kunne fortsætte
Scenarie 2:
Når du kører PowerStore System Health Check (SHC), kan følgende meddelelse observeres på en PowerStoreOS 4.0.x-klynge:
- Systemtilstandskontrol (SHC) returnerer muligvis følgende meddelelse:
Found problematic attributes in volume groups. (KB#000238653).
- Hvis testen af systemtilstandskontrol (SHC) udføres fra CLI (Command Line Interface), vises følgende muligvis:
[SVC:service@123456-A ~]$ svc_health_check run -rhc invalid_vg_uuid_check Name Location Status Description Invalid Volume Group UUID Check node_a Failed Found problematic attributes in volume groups. (KB#000238653) SUMMARY Status: Failed Passed: 0 Failed: 1 Total: 1
Bemærk: Resultaterne kan afvige fra ovenstående, afhængigt af hvilke noder testen mislykkedes. - Denne SHC-kontrol mislykkes, hvis der findes en diskenhedsgruppe med en ugyldig UUID.
- Læs afsnittet Løsning i denne Knowledge Base-artikel for at se, om der skal foretages korrigerende handlinger.
Disse helbredstjek er PUHC- og SHC-kontroller uden for versionerne, som findes i den tynde pakke til sundhedstjekket, der downloades fra Dells drivere og downloads . Se afsnittet Yderligere oplysninger for at få oplysninger om den tynde pakke til sundhedstjekket.
Cause
Diskenhedsgrupper er en ny funktion i System Manager (SYM). Hvis der er en diskenhedsgruppe uden medlemmer i Control Path (CP), beholder den en nul-id. Dette ugyldige id kan forårsage problemer, når du tilføjer eller fjerner diskenhedsmedlemmer senere.
Resolution
Scenarie 1:
Hvis tilstandskontrollen før opgradering (PUHC) viser en meddelelse om eksisterende diskenhedsgrupper uden medlemmer på en PowerStoreOS 3.x- eller 4.x-klynge:
- Denne meddelelse angiver, at der findes diskenhedsgrupper med nul (0)medlemsvolumener i PowerStore-klyngen.
- I PowerStore Manager skal du gå til Lagerdiskenhedsgrupper > og finde diskenhedsgrupper med nul (0)medlemsdiskenheder.

- Vælg en diskenhedsgruppe med nul (0) medlemsvolumener, klik på rullemenuen Flere handlinger, og vælg Slet.

- Når alle diskenhedsgrupper med nul (0) medlemsdiskenheder er blevet slettet, skal du fortsætte med ikke-forstyrrende softwareopgradering (NDU).
Scenarie 2:
Hvis System Health Check (SHC) viser en meddelelse om fundne problematiske attributter i diskenhedsgrupper. (KB#000238653) på en PowerStoreOS 4.0.x-klynge:
- Denne meddelelse angiver, at der fandtes diskenhedsgrupper med nul (0) medlemsenheder på en PowerStoreOS 3.x-klynge og senere blev opgraderet til PowerStoreOS 4.0.x.
- Efter softwareopgraderingen til PowerStoreOS 4.0.x blev der føjet diskenheder til denne diskenhedsgruppe, der tidligere havde nul (0) medlemsdiskenheder.
- Denne række administrative handlinger kan have introduceret et ugyldigt UUID i PowerStore-klyngen med 00000000000000000000000000000000000000000.
- Kontakt teknisk support for at få hjælp til at løse dette problem. Se KB # 000238653 for hurtig opmærksomhed og opløsning.
Additional Information
Du kan finde flere oplysninger om den tynde pakke til sundhedstjekket i KB 000192601 PowerStore: Sådan tjekker du klyngens tilstand før softwareopgradering ved hjælp af helbredstjekket og systemtjekket før opgradering
Du kan finde flere oplysninger om alle helbredstjek i den tynde pakke med sundhedstjekket i KB# 000214752 PowerStore: Landingsside for In Market (off-release) af systemtilstandstjek