PowerStore. Диагностика системы перед модернизацией (PUHC) и диагностика системы (SHC), чтобы определить, существует ли группа томов, в которой нет участников.
Summary: Эти проверки предназначены для обнаружения любых групп томов, не имеющих членов, или при наличии томов с важными внутренними атрибутами. При обнаружении этой проблемы проверка PUHC (empty_vg_no_members) остановит обновление до PowerStoreOS 4.0.x. Проверка SHC (invalid_vg_uuid_check) завершится сбоем, если эта проблема обнаружена в кластере под управлением PowerStoreOS 4.0.x. ...
Symptoms
PowerStore Pre-Upgrade Health Check (PUHC) и System Health Check (SHC) могут обнаружить эту проблему при запуске в следующих выпусках PowerStoreOS:
- PowerStoreOS 3.x
- PowerStoreOS 4.x
Сценарий 1.
При запуске диагностики системы перед модернизацией (Pre-Upgrade Health Check, PUHC) перед обновлением до PowerStoreOS 4.0.x может отображаться следующее сообщение:
- Диагностика системы перед модернизацией (PUHC) может вернуть следующее сообщение:
Exists volume groups with no members. Please delete those volume groups and then add them back after NDU. KB # 000238653 (empty_vg_no_members).
- Эта проверка PUHC завершается ошибкой, если группа томов существует и не содержит ни одного (0) тома-участника
- Сведения о корректирующих действиях см. в разделе «Решение » данной статьи базы знаний.
- Бесперебойное обновление программного обеспечения (NDU) не будет продолжено
Сценарий 2.
При запуске PowerStore System Health Check (SHC) в кластере PowerStoreOS 4.0.x может отображаться следующее сообщение:
- Процедура диагностики системы (SHC) может вернуть следующее сообщение:
Found problematic attributes in volume groups. (KB#000238653).
- Если проверка работоспособности системы (SHC) выполняется из интерфейса командной строки (CLI), может отображаться следующее:
[SVC:service@123456-A ~]$ svc_health_check run -rhc invalid_vg_uuid_check Name Location Status Description Invalid Volume Group UUID Check node_a Failed Found problematic attributes in volume groups. (KB#000238653) SUMMARY Status: Failed Passed: 0 Failed: 1 Total: 1
Примечание. Результаты могут отличаться от приведенных выше в зависимости от того, на каких узлах тест не был пройден. - Эта проверка SHC завершается сбоем, если существует группа томов с недопустимым UUID.
- Сведения о корректирующих действиях см. в разделе «Решение » данной статьи базы знаний.
Данные диагностики системы представляют собой вневыпускные проверки PUHC и SHC, которые содержатся в «тонком» пакете диагностики системы, скачанном с сайта Dell Драйверы и скачиваемые материалы . Сведения о тонком пакете Health Check см. в разделе Дополнительная информация.
Cause
Группы томов — это новая функция в System Manager (SYM). Если в пути управления (CP) имеется группа томов, в которой нет ни одного члена, идентификатор остается полностью нулевым. Этот недействительный идентификатор может стать причиной проблем при последующем добавлении или удалении участников тома.
Resolution
Сценарий 1.
Если во время диагностики системы перед модернизацией (Pre-Upgrade Health Check, PUHC) выводится сообщение о существовании групп томов, в которых нет членов в кластере PowerStoreOS 3.x или 4.x:
- Это сообщение указывает на то, что в кластере PowerStore имеются группы томов с нулевыми (0)томами-участниками .
- В PowerStore Manager перейдите в раздел Storage > Volume Groups и найдите все группы томов , в которых нет (0)томов.

- Выберите группытомов с нулевыми (0) томами-участниками, щелкните раскрывающееся меню Больше действий и выберите Удалить.

- После удаления всех групп томов с нулевым (0) количеством томов перейдите к бесперебойному обновлению ПО (NDU).
Сценарий 2.
Если процедура диагностики системы (SHC) выдает сообщение о найденных проблемных атрибутах в группах томов. (KB#000238653) в кластере PowerStoreOS 4.0.x:
- Это сообщение указывает на то, что в кластере PowerStoreOS 3.x, а затем модернизированном до PowerStoreOS 4.0.x присутствует группа томов с нулевым (0) количеством томов .
- После обновления ПО до PowerStoreOS 4.0.x в эту группу томов были добавлены тома, в которых ранее не было ни одного (0) тома.
- Эта серия административных действий могла привести к появлению недопустимого UUID в кластере PowerStore, состоящем из 00000000000000000000000000000000.
- Чтобы решить эту проблему, обратитесь за помощью в службу технической поддержки . Сошлитесь со статьей базы знаний # 000238653 для ускорения рассмотрения и разрешения проблемы.
Additional Information
Дополнительные сведения о «тонком» пакете диагностики системы см. в статье базы знаний 000192601 PowerStore. Проверка состояния кластера перед модернизацией ПО с помощью диагностики системы перед модернизацией и проверки системы
Дополнительные сведения обо всех проверках состояния в «тонком» пакете диагностики системы см. в статье базы знаний KB# 000214752 PowerStore. Начальная страница для диагностики системы на рынке (не выпущено)