PowerStore : Bilan de santé préalable à la mise à niveau pour détecter un problème de réservation SCSI-3 obsolète

Summary: Le bilan de santé préalable à la mise à niveau (Pre-Upgrade Health Check, PUHC) vérifie le système à la recherche de réservations SCSI-3 obsolètes.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Le bilan de santé préalable à la mise à niveau (Pre-Upgrade Health Check, PUHC) vérifie le système à la recherche de réservations SCSI-3 obsolètes.

Le bilan de santé PowerStore (PUHC) peut échouer en raison d’une réservation SCSI-3 avec un enregistrement SCSI non valide ou incompatible, avec l’erreur suivante : 

Found stale SCSI3 reservations. Please contact your service provider. (off_release_stale_scsi3_reg_check). 

Error code: 0xE10050020204.

Le bilan de santé est un contrôle PUHC hors version qui est contenu dans le package dynamique Health Check téléchargé à partir du site Pilotes et téléchargements de Dell . Reportez-vous à la section Informations supplémentaires pour plus d’informations sur le package léger Health Check. 

Exemple de vérification PUHC détectant ce problème :

Vérification PUHC de réservation SCSI3 obsolète

Cause

Dans des situations normales, chaque fois qu’un hôte réserve une réservation SCSI-3 sur un volume, il doit y avoir un ou plusieurs enregistrements SCSI correspondant à celui-ci (en fonction du nombre de chemins de l’hôte, chaque enregistrement correspond à un I_T_L).

Dans de rares cas, un enregistrement SCSI est effacé, mais la réservation SCSI-3 correspondante reste du côté PowerStore, pointant vers l’enregistrement SCSI effacé. La mise à niveau sans perturbation vers 4.0.0.X de ces appliances peut échouer lors de l’étape de transfert SYM.

Resolution

Ce problème est résolu dans PowerStoreOS version 4.1.0.1 

Les mises à niveau de PowerStoreOS version 3.x vers 4.1.0.1+ ne rencontreront pas ce problème. 

 

Le problème détecté par ce PUHC est résolu avec PowerStoreOS version 4.0.1.3 et 4.1.0 (ou ultérieure).

Solution de contournement :

Si le niveau de code cible d’une mise à niveau en attente est inférieur à la version 4.1.0.1, procédez comme suit :

Demandez au client d’effectuer les deux actions suivantes :

  1. Planifiez une fenêtre de maintenance pour la mise à niveau sans perturbation afin de minimiser le risque de nouvelles réservations pendant la mise à niveau sans perturbation. 
  2. Effectuez une mise à niveau en deux étapes à partir de PowerStoreOS version 3.0.x, ou des versions 3.2.x à 4.0.x en procédant d’abord à la mise à niveau vers la dernière version 3.6.x.

Additional Information

Affected Products

PowerStore
Article Properties
Article Number: 000246358
Article Type: Solution
Last Modified: 02 Sep 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.