NetWorker: Keystore file is not accessible with provided password during upgrade process

Summary: Upgrade to 19.11.0.4 NetWorker fails "Keystore file is not accessible with provided password" error message when the password ends with ! = (exclamation space equal)

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Symptoms

Upgrade Issues

The following symptoms were encountered during the upgrade to 19.11.0.4 when the keystore password ends with ! = (exclamation space equal):

  • Keystore file is not accessible with provided password displays during the NetWorker Web User Interface (NWUI) portion of the upgrade.
  • Error window File incorrect Keystore file is not accessible with the provided password when entering the correct keystore password at the NWUI upgrade step Configure NetWorker Management Web UI Server Keystore.

Cause

Root Cause Analysis

The Keystore file is not accessible with provided password issue occurred during the NWUI portion of the upgrade to 19.11.0.4.

The correct keystore password was confirmed using the keytool command, and the same password was successful for the NetWorker installation and the NMC installation.

Specific Conditions

The File incorrect Keystore file is not accessible with provided password error message was encountered at the NWUI upgrade step Configure NetWorker Management Web UI Server Keystore when entering the correct keystore password. The keystore password ends with ! = (exclamation space equal):

  • The keytool command was used to verify the keystore password.
  • The same password was used successfully for previous installations.

Error Messages

The following error message was encountered:

File incorrect
Keystore file is not accessible with provided password

Resolution

Troubleshooting Keystore File Accessibility

The issue of the Keystore file not being accessible with the provided password, confirm the problem with these steps:

  • Use the keytool command to confirm the password being used is the correct one.

Engineering assistance can be requested to additionally troubleshoot the issue:

# Run the keytool command to verify the keystore password
$ keytool -list -v -keystore [keystore_file] -storepass [password]
Replace [keystore_file] and [password] with the keystore file and password.
 
If the issue persists, contact Dell Support for further assistance.
Article Properties
Article Number: 000336305
Article Type: Solution
Last Modified: 16 Feb 2026
Version:  3
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