iDRAC10: Не вдається ввійти за допомогою облікових записів служби каталогів
Summary: Автентифікація або авторизація iDRAC10 за допомогою облікових записів служби каталогів не працює за певних умов.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Користувач не може увійти в iDRAC10 за допомогою інтегрованого облікового запису Directory Service з повідомленням про помилку:
- "RAC0212"
Або
- "RAC0506"
- «Така сама конфігурація інтеграції служби каталогів працює в системах iDRAC9».
Функція «Тест» служби каталогів показує «Помилку компіляції фільтра» під час пошуку користувача або авторизації користувача як невдалу.
[20:17:38]: "Dial" Performed. Result: "Dial success" LDAP URL: "ldap://dcfqdn:389"
[20:17:38]: "Bind" Performed. Result: "Bind success" Bind User: "test.user@example.com"
[20:17:38]: "UserSearch" Performed. Result: "Filter Compile Error, Err: LDAP Result Code 201 "Filter Compile Error": ldap: invalid characters for escape in filter: encoding/hex: invalid byte: U+002C ','"
Cause
У iDRAC10 запити LDAP будуються на основі атрибутів об'єктів, повернутих із проникного пошуку. Якщо результат містить спеціальні символи LDAP у "cn" або "distinctedName", вони не будуть належним чином екрановані.
До образливих символів відносяться "," "(" ")" ".".
/* User Search */
"attribute_list": [
"cn",
"samaccountname",
"sn",
"userPrincipalName",
"objectGUID",
"objectSid",
"sAMAccountName",
"mail",
"userAccountControl",
"msDS-UserPasswordExpiryTimeComputed"
]
/* Group Search */
"attribute_list": [
"cn",
"distinguishedName",
"groupType",
"objectClass",
"objectSid",
"sAMAccountName"
]
Resolution
Цю поведінку вирішено в майбутньому випуску мікропрограми iDRAC10 1.20.80.50.
Affected Products
iDRAC10 - 1.10.xx Series, iDRAC10 - 1.20.xx SeriesArticle Properties
Article Number: 000352805
Article Type: Solution
Last Modified: 04 Sep 2025
Version: 2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.