iDRAC10:無法使用目錄服務帳戶登入
Summary: 在某些情況下,目錄服務帳戶的 iDRAC10 驗證或授權無法運作。
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Not all product versions are identified in this article.
Symptoms
使用者無法使用目錄服務整合帳戶登入 iDRAC10,並出現錯誤訊息:
- “RAC0212”
或
- “RAC0506”
- 「相同的目錄服務整合組態正在 iDRAC9 系統上運作。」
目錄服務「測試」功能在使用者搜索或使用者授權中顯示「篩選器編譯錯誤」失敗。
[20:17:38]: "Dial" Performed. Result: "Dial success" LDAP URL: "ldap://dcfqdn:389"
[20:17:38]: "Bind" Performed. Result: "Bind success" Bind User: "test.user@example.com"
[20:17:38]: "UserSearch" Performed. Result: "Filter Compile Error, Err: LDAP Result Code 201 "Filter Compile Error": ldap: invalid characters for escape in filter: encoding/hex: invalid byte: U+002C ','"
Cause
在 iDRAC10 中,LDAP 查詢是根據先前搜尋傳回的物件屬性建立。如果結果在「cn」或「competeedName」中包含LDAP特殊字元,則無法正確轉義這些字元。
有問題的字元包括“,”(“,”)“”“.”。
/* User Search */
"attribute_list": [
"cn",
"samaccountname",
"sn",
"userPrincipalName",
"objectGUID",
"objectSid",
"sAMAccountName",
"mail",
"userAccountControl",
"msDS-UserPasswordExpiryTimeComputed"
]
/* Group Search */
"attribute_list": [
"cn",
"distinguishedName",
"groupType",
"objectClass",
"objectSid",
"sAMAccountName"
]
Resolution
此行為已在即將推出的 iDRAC10 韌體版本 1.20.80.50 中解決。
Affected Products
iDRAC10 - 1.10.xx Series, iDRAC10 - 1.20.xx SeriesArticle Properties
Article Number: 000352805
Article Type: Solution
Last Modified: 04 Sep 2025
Version: 2
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