iDRAC10: Kan niet aanmelden met Directory Service Accounts
Summary: iDRAC10-verificatie of -autorisatie met Directory Service-accounts werkt onder bepaalde omstandigheden niet.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
De gebruiker kan zich niet aanmelden bij iDRAC10 met een geïntegreerd account van Directory Service met de volgende foutmelding:
- "RAC0212"
Of
- "RAC0506"
- 'Dezelfde integratieconfiguratie van de Directory Service werkt op iDRAC9-systemen.'
De functie "Test" van de directoryservice geeft "Filter Compile Error" bij UserSearch of User Authorization weer als mislukt.
[20:17:38]: "Dial" Performed. Result: "Dial success" LDAP URL: "ldap://dcfqdn:389"
[20:17:38]: "Bind" Performed. Result: "Bind success" Bind User: "test.user@example.com"
[20:17:38]: "UserSearch" Performed. Result: "Filter Compile Error, Err: LDAP Result Code 201 "Filter Compile Error": ldap: invalid characters for escape in filter: encoding/hex: invalid byte: U+002C ','"
Cause
In iDRAC10 worden de LDAP-query's gebouwd op basis van objectkenmerken die worden geretourneerd door een vorige zoekopdracht. Als het resultaat speciale LDAP-tekens bevat in de "cn" of "distinctedName", worden deze niet correct escaped.
Aanstootgevende tekens zijn onder meer "", "(", ")", ".".
/* User Search */
"attribute_list": [
"cn",
"samaccountname",
"sn",
"userPrincipalName",
"objectGUID",
"objectSid",
"sAMAccountName",
"mail",
"userAccountControl",
"msDS-UserPasswordExpiryTimeComputed"
]
/* Group Search */
"attribute_list": [
"cn",
"distinguishedName",
"groupType",
"objectClass",
"objectSid",
"sAMAccountName"
]
Resolution
Dit gedrag wordt opgelost in de komende iDRAC10 firmwarerelease 1.20.80.50.
Affected Products
iDRAC10 - 1.10.xx Series, iDRAC10 - 1.20.xx SeriesArticle Properties
Article Number: 000352805
Article Type: Solution
Last Modified: 04 Sep 2025
Version: 2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.