NetWorker: NWUI Dashboard Error "Unable to Retrieve Information"
Summary: The NetWorker User Interface (NWUI) dashboard fails to display activity data and shows the error message: "Unable to retrieve information."
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Symptoms
- NWUI dashboard fails to display activity data.
- Monitoring logs show connection errors.
Error in fetching count of activities based on status from Monitoring Service. java.net.ConnectException: Connection refused
- NWUI ports 9095 and 5435 are confirmed open.
Cause
The use of Java OpenJDK 8 build 201 which is not supported for NetWorker, causes this issue.
Resolution
1. Install NetWorker Runtime Environment (NRE).
2. Reconfigure NetWorker Service.
- Stop the NetWorker service.
- Run the following script:
/opt/nsr/authc-server/scripts/authc_configure.sh
- Point the Java path to the NRE installation path.
- Create a new keystore.
- Start the NetWorker service.
3. Reconfigure NWUI Service
- Stop the NWUI service
- Run the following script:
/opt/nwui/scripts/nwui_configure.sh
- Point the Java path to the NRE location
- Create a new keystore and database
- Start the NWUI service
4. Validate
- Launch NWUI
- Confirm that the dashboard loads successfully and displays activity data.
Affected Products
NetWorker FamilyArticle Properties
Article Number: 000388189
Article Type: Solution
Last Modified: 21 Nov 2025
Version: 2
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