Dell ThinOS Clients Cannot Connect to Amazon Workspaces Starting January 2026

Summary: Learn about Dell ThinOS 9 and 10 clients not connecting to Amazon Workspaces (AWS) starting January 2026 if they are not running AWS 2025.0 or later.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Affected Operating Systems:

  • Dell ThinOS 10
  • Dell ThinOS 9

Cause

Due to security concerns, Amazon is adding enforcement that prevents clients with AWS agents older than 2025.0 from attaching to Amazon Workspace environments starting January 2026.

Resolution

Reference the list below for appropriate corrective actions.

  • ThinOS 9 clients that are still eligible for quarterly software updates should upgrade to ThinOS 9 2508 and use the AWS 2025.0 package.
  • ThinOS 9 clients (legacy Wyse clients) that are no longer eligible for quarterly updates should contact Dell Support and request a solution.
  • ThinOS 10 clients should update to the AWS 2025.0 update prior to January 2026. The AWS 2025.0 update is available at Support for Dell ThinOS. For more information about installation, refer to the AWS PKG file’s installation instructions.

Affected Products

Dell ThinOS
Article Properties
Article Number: 000391052
Article Type: Solution
Last Modified: 21 Nov 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.