Serwer Dell 9712a: F3MU100 oprogramowania wewnętrznego rozwiązuje problem z krótkim czasem letnim w urządzeniu Micron 9550 E1. S SSD
Summary: Mikron 9550 E1. Dyski SSD S (numery części Dell HRF8G, 2G1RR) mogą przerwać krótki autotest urządzenia (DST), jeśli dziennik DST (identyfikator dziennika 0x06) zostanie odczytany w ciągu 2 sekund od uruchomienia z powodu nieprawidłowego wskaźnika. ...
Symptoms
Zaobserwowane zachowanie
Po uruchomieniu krótkiego autotestu urządzenia (DST) mogą pojawić się następujące objawy, jeśli dziennik DST (Log ID 0x06) jest dostępna w ciągu pierwszych 2 sekund:
- Krótki czas letni zgłasza awarię.
- Podczas testowania segmentu oceniane są nieprawidłowe dane, co skutkuje niepowodzeniem wyniku testu.
Cause
Główna przyczyna błędu krótkiego czasu letniego w urządzeniu Micron 9550 E1. S Dyski SSD
Dostęp do dziennika DST wrażliwy na czas
Po zainicjowaniu krótkiego autotestu urządzenia (DST) uzyskanie dostępu do dziennika DST (Log ID 0x06) w ciągu pierwszych 2 sekund może spowodować awarię.
- Oprogramowanie wewnętrzne używa wewnętrznego wskaźnika do odwoływania się do obszaru pamięci strukturalnej podczas DST.
- W krótkim oknie po rozpoczęciu krótkiego czasu letniego wskaźnik jest nieprawidłowo ustawiony.
- Ten nieprawidłowy wskaźnik jest używany w jednym z testów segmentu, co powoduje, że test ocenia nieprawidłowe dane.
- Rezultatem jest niepowodzenie DST, mimo że sprzęt SSD działa.
Wada oprogramowania wewnętrznego
Problem wynika z wcześniejszych wersji oprogramowania wewnętrznego, które nie inicjują poprawnie wartości wskaźnika podczas krótkiej sekwencji DST.
Resolution
Aktualizacja Micron 9550 E1. s oprogramowanie wewnętrzne dysku SSD w celu rozwiązania problemu z krótkim czasem letnim.
Wymagania wstępne
- Zidentyfikuj dyski SSD (Micron 9550 E1. S) zainstalowanych w serwerach PowerEdge. Numery części firmy Dell, których dotyczy problem: HRF8G, 2G1RR.
- Pobierz pakiet oprogramowania układowego Micron F3MU100 z oficjalnej strony Micron (link zewnętrzny)
W przypadku każdego systemu, którego dotyczy ten problem, wpis w dzienniku błędów wskazujący błąd segmentacji (Seg Fault) pojawia się w dzienniku autotestu dysku. Ten dziennik zawiera zapisy ostatnich 20 przebiegów testów DST. Po aktualizacji oprogramowania wewnętrznego, po wykonaniu 20 kolejnych testów DST, Seg Fault Wpis nie będzie już wyświetlany w dzienniku.