IDPA DP5x00 and DP8x00: SupportAssist Registration Failure After Upgrade to 2.7.9

Summary: On Integrated Data Protection Appliance (IDPA) models with a physical Data Domain (DP5800, DP5900, DP8300, DP8400, DP8800, or DP8900), the SupportAssist upgrade may fail. This causes the registration to Secure Connect Gateway (SCG) to fail. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

SupportAssist Upgrade failure after IDPA upgrade

Following an upgrade of an IDPA appliance (DP5x00 or DP8x00 series) the attached Data Domain may report that the SupportAssist upgrade was not successful. An alert such as the following is shown:  

Id       Post Time               Severity   Class               Object   Message
------   ----------------------  --------   -----------------   ------   -------------------------------------------------------------
p0-339   2025-09-12 16:27:05     ERROR      SystemMaintenance   EVT-TLMY-00003: Upgrade from ESRS to SupportAssist failed.

Errors shown when performing SupportAssist registration

  • Registration can fail with an error stating that the Access Key and PIN are not valid.
    example error message for access key 
  • Alternatively, the registration process may return “Failed to Connect to SupportAssist.”
    example error message for failed to connect 

Caution: For IDPA model DP4400, this procedure does NOT apply. Refer to article IDPA DP4400: SupportAssist Registration Failure After Upgrade

Cause

Underlying Issue with SupportAssist Upgrade

During the appliance upgrade, the internal process that migrates the configuration from ESRS to SupportAssist can terminate prematurely.

  • The migration script does not update the authentication key stored for the ESE (Embedded Service Enabler) service.
  • The Data Domain holds an outdated or invalid access key, causing SupportAssist registration to fail.

Resolution

Contact Dell Support to manually perform the upgrade of SupportAssist from the Data Domain. Reference this article to expedite the resolution.

Affected Products

PowerProtect DP5800, PowerProtect DP8300, PowerProtect DP8800, PowerProtect DP5900, PowerProtect DP8400, PowerProtect DP8900

Products

Integrated Data Protection Appliance Family
Article Properties
Article Number: 000400333
Article Type: Solution
Last Modified: 10 Dec 2025
Version:  1
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