OpenManage Enterprise: LDAP Users Unable to Log in after Upgrading to Version 4.6.0
Summary: After successfully completing the upgrade to version 4.6.0, Lightweight Directory Access Protocol (LDAP) users are unable to log in. Checking the Directory Services configuration from Application > Users shows that the LDAP configuration is missing. ...
Symptoms
After completing the upgrade to version 4.6.0, logging into the web user interface using an LDAP account fails with a general login failure message.
Checking the directory configuration from Application Settings > Users > Directory Services, the LDAP configuration is missing.

Any attempt to add the configuration back fails with the following error:
CSEC5006 - Unable to save account provider information to the database.

Cause
The post upgrade task was interrupted before the AES encryption subtask could complete. This only impacts instances that leverage the LDAP directory type.
Resolution
Rerun the post upgrade task and wait until successful completion.
IMPORTANT: This task should be completed before attempting any plugin upgrade or service or appliance restart.
To check the status of the post upgrade task:
- Browse to Monitor > Jobs.
- Clear the filters by clicking Clear All Filters.
- Expand the Advanced Filters and select Post_Upgrade_Task for the Job Type filter.
- Select the job and click the View Details button from the right-side pane.
- If the previous job status shows Stopped or Canceled, click Restart Job
The post upgrade task performs all discovery jobs as the last step. The LDAP settings are accessible once the discoveries are started. Log out and log back in using LDAP credentials to verify.