Dell Peripheral Model and Color Does Not Match DDPM Image
Summary: Learn more about why the model and color of the peripheral may not match the image displaying in the Dell Display and Peripheral Manager (DDPM) application.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
The image displaying in DDPM may not match the Dell peripheral that has been connected using the application.
An example of this can be seen using the white KM5221W keyboard and mouse. An image of a black KB500 keyboard and MS300 mouse is seen on-screen in DDPM.

Affected Platforms:
- Dell Mouse and Keyboard peripherals
- Dell Laptop families
- Dell Desktop families
- Dell Tablet families
- Dell Workstation families
Cause
DDPM is not designed to display an image of every possible peripheral combination in every available color. The KM5221W keyboard and mouse combines the KB500 keyboard and MS300 mouse and is available in black and white. The KB500 keyboard and MS300 mouse sold individually are available in black.
Resolution
Note: DDPM is working as it is expected to when the KM5221W in white displays on-screen as an image of the KB500 and MS300 in black.
There is no requirement to match colors with a connected peripheral. It does not affect what the application is designed to do or its performance on the device.
Affected Products
Dell All-in-One, Dell Pro All-in-One, Dell Pro Max Micro, Dell Pro Max Slim, Dell Pro Max Tower, Dell Pro Micro, Dell Pro Slim, Dell Pro Tower, Dell Slim, Inspiron, OptiPlex, Vostro, XPS, G Series, G Series, Dell Laptops, Dell Plus, Dell Pro
, Dell Pro Max, Dell Pro Plus, Dell Pro Premium, Inspiron, Latitude, Dell Pro Rugged, Vostro, XPS, Mobile Devices, XPS Tablets, Fixed Workstations, Mobile Workstations, Dell Display and Peripheral Manager, Dell Pro Keyboard and Mouse KM5221W, Dell Pro Keyboard KB500, Dell Pro Mouse MS300
...
Article Properties
Article Number: 000462027
Article Type: Solution
Last Modified: 08 May 2026
Version: 2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.