Article Number: 519726

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VPLEX: Troubleshooting Array Management Provider (AMP) Connectivity

Summary: Troubleshooting steps when the AMP connectivity-status reports 'unreachable' and/or when registering an AMP fails with the error, 'Failed to ping AMP....Cause: Unable to connect'

Primary Product: VPLEX GeoSynchrony

Product: VPLEX VS6 more...

Last Published: 20 Mar 2020

Article Type: Break Fix

Published Status: Online

Version: 4

VPLEX: Troubleshooting Array Management Provider (AMP) Connectivity

Article Content

Issue


  • AMP connectivity-status reports 'unreachable';
/clusters/cluster-1/storage-elements/array-providers/AMP_NAME

Attributes:
Name Value
------------------- ------------
array -
connectivity-status unreachable
ip-address X.X.X.X
port 5989
provider-type SMI-S
use-ssl true
username admin

 
  • Attempting to register an AMP fails with the following error message;
amp register: Evaluation of <<amp register -n AMP_NAME -i X.X.X.X -u admin -t SMI-S -p 5989 -c cluster-1>> failed.
cause: Failed to register array management provider.
cause: Failed to ping AMP 'AMP_NAME'. com.emc.vplex.via.orca.amp.AMPException: Failed to ping provider 'AMP_NAME'. Cause: Unable to connect
Cause
  • IP connectivity issues between the VPlex management-server/MMCS and the AMP host.
  • Changes to the existing firewall rules
  • Change of credentials on the SMI-S provider
Resolution
1. Ping the IP address of the AMP host from the management-server (VS2) or the MMCS (VS6) to ensure that it is pingable. If the IP is not pingable, please ensure that any connectivity issues between the VPlex management-server/MMCS are resolved;

service@ManagementServer:~> ping X.X.X.X

2. If the existing AMP configuration's connectivity-status reports 'unreachable', unregister it from the VPlexcli and then re-register it;

VPlexcli:/> amp unregister -n AMP_NAME -c cluster-1
Unregistering an array-provider will permanently remove it. Do you wish to proceed? (Yes/No) Yes
Successfully unregistered array provider 'AMP_NAME' on cluster 'cluster-1'.


3. During the registration of AMP, a URL is created using three values: protocol, host and port. The management-server/MMCS attempts to try and connect to this URL during the registration process. If this URL is inaccessible, the registration of AMP fails. The protocol used by the ECOM server is either HTTP (5988) or HTTPS (5989). Both ports along with port 443 must be open in both directors (inbound/outbound) in the firewall configuration. For a list of all firewall exceptions, refer to the PDF attachment in the bottom of this article labelled, 'Provisioning with EMC VIAS.pdf';
 
SMI-S Firewall Considerations For VIASpage 12
Creating TCP Firewall Rulespage 13
Setting ECOM Security (credentials) page 13

4. To check whether the ports are open, perform a telnet to the AMP IP by specifying the port/s from the management-server/MMCS. If any of the ports used are blocked, please consult step 3 above to ensure that the relevant ports are open/allowed in the firewall;

Instance where port 5988 is blocked:

service@ManagementServer:~> telnet X.X.X.X 5988
Trying X.X.X.X...
telnet: connect to address X.X.X.X: Connection timed out


Instance where port 5989 is open:
service@essvplex0415-mc:/var/log/VPlex/cli> telnet X.X.X.X 5989
Trying X.X.X.X...
Connected to X.X.X.X.
Escape character is '^]'.
Connection closed by foreign host.


5. When attempting to register AMP using HTTPS (port 5989), ensure that the --use-ssl argument is specified;

VPlexcli:/> amp register -n AMP_NAME -i X.X.X.X -u admin -t SMI-S -p 5989 -c CLUSTER_ID --use-ssl


6. The default 'admin' credentials for registering AMP are as follows (note that this is not the VPlex admin password!)
user: admin
pwd: #1Password

7. If all of the above steps fail to re-mediate the issue, please consider rebooting the AMP host and then try registering AMP. If the registration process still fails, please raise a service request with Dell EMC.

Notes

Issue


  • AMP connectivity-status reports 'unreachable';
/clusters/cluster-1/storage-elements/array-providers/AMP_NAME

Attributes:
Name Value
------------------- ------------
array -
connectivity-status unreachable
ip-address X.X.X.X
port 5989
provider-type SMI-S
use-ssl true
username admin

 
  • Attempting to register an AMP fails with the following error message;
amp register: Evaluation of <<amp register -n AMP_NAME -i X.X.X.X -u admin -t SMI-S -p 5989 -c cluster-1>> failed.
cause: Failed to register array management provider.
cause: Failed to ping AMP 'AMP_NAME'. com.emc.vplex.via.orca.amp.AMPException: Failed to ping provider 'AMP_NAME'. Cause: Unable to connect
Cause
  • IP connectivity issues between the VPlex management-server/MMCS and the AMP host.
  • Changes to the existing firewall rules
  • Change of credentials on the SMI-S provider
Resolution

1. Ping the IP address of the AMP host from the management-server (VS2) or the MMCS (VS6) to ensure that it is pingable. If the IP is not pingable, please ensure that any connectivity issues between the VPlex management-server/MMCS are resolved;

service@ManagementServer:~> ping X.X.X.X

2. If the existing AMP configuration's connectivity-status reports 'unreachable', unregister it from the VPlexcli and then re-register it;

VPlexcli:/> amp unregister -n AMP_NAME -c cluster-1
Unregistering an array-provider will permanently remove it. Do you wish to proceed? (Yes/No) Yes
Successfully unregistered array provider 'AMP_NAME' on cluster 'cluster-1'.


3. During the registration of AMP, a URL is created using three values: protocol, host and port. The management-server/MMCS attempts to try and connect to this URL during the registration process. If this URL is inaccessible, the registration of AMP fails. The protocol used by the ECOM server is either HTTP (5988) or HTTPS (5989). Both ports along with port 443 must be open in both directors (inbound/outbound) in the firewall configuration. For a list of all firewall exceptions, refer to the PDF attachment in the bottom of this article labelled, 'Provisioning with EMC VIAS.pdf';
 
SMI-S Firewall Considerations For VIASpage 12
Creating TCP Firewall Rulespage 13
Setting ECOM Security (credentials) page 13

4. To check whether the ports are open, perform a telnet to the AMP IP by specifying the port/s from the management-server/MMCS. If any of the ports used are blocked, please consult step 3 above to ensure that the relevant ports are open/allowed in the firewall;

Instance where port 5988 is blocked:

service@ManagementServer:~> telnet X.X.X.X 5988
Trying X.X.X.X...
telnet: connect to address X.X.X.X: Connection timed out


Instance where port 5989 is open:
service@essvplex0415-mc:/var/log/VPlex/cli> telnet X.X.X.X 5989
Trying X.X.X.X...
Connected to X.X.X.X.
Escape character is '^]'.
Connection closed by foreign host.


5. When attempting to register AMP using HTTPS (port 5989), ensure that the --use-ssl argument is specified;

VPlexcli:/> amp register -n AMP_NAME -i X.X.X.X -u admin -t SMI-S -p 5989 -c CLUSTER_ID --use-ssl


6. The default 'admin' credentials for registering AMP are as follows (note that this is not the VPlex admin password!)
user: admin
pwd: #1Password

7. If all of the above steps fail to re-mediate the issue, please consider rebooting the AMP host and then try registering AMP. If the registration process still fails, please raise a service request with Dell EMC.

Notes

Article Attachments

Attachments

Provisioning_with_EMC_VIAS.pdf

Article Properties

First Published

Fri Mar 30 2018 00:01:43 GMT

First Published

Fri Mar 30 2018 00:01:43 GMT

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