ECS:OBS:xDoctor:プライマリー ノード コントロール チェック メッセージが表示された後、xDoctorの実行に失敗する
Summary: xDoctorの実行に失敗し、1秒後に終了します。
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
xDoctorの実行に失敗し、1秒後に終了します。
admin@ecs1node1:~> sudo xdoctor --hr
2025-11-19 10:44:03,765: 5.1-106.1 - INFO : Adding Work - Job:1763549043 (P9) [* * * * * *] (--scope=SYSTEM --suite=default): From CLI
2025-11-19 10:44:03,766: 5.1-106.1 - INFO : Executing Job:1763549043 - session_1763549043.766
2025-11-19 10:44:03,798: 1763549043.766 - INFO : Initializing xDoctor v5.1-106.1 ...
2025-11-19 10:44:03,809: 1763549043.766 - INFO : xDoctor Composition - Full Diagnostic Suite for ECS
2025-11-19 10:44:03,814: 1763549043.766 - INFO : Starting xDoctor session_1763549043.766 ... (SYSTEM)
2025-11-19 10:44:03,814: 1763549043.766 - INFO : Primary Node Control Check ...
Traceback (most recent call last):
File "/opt/emc/xdoctor/lib/xdoctor/lib/cli.py", line 526, in __execute
engine = Engine(session_id)
^^^^^^^^^^^^^^^^^^
File "/opt/emc/xdoctor/lib/xdoctor/core/engine.py", line 281, in __init__
if self.system.is_primary() == False:
^^^^^^^^^^^^^^^^^^^^^^^^
File "/opt/emc/xdoctor/lib/xdoctor/lib/system.py", line 799, in is_primary
return self.config['hosts'][self.host]['state'].startswith('M')
~~~~~~~~~~~~~~~~~~~~~^^^^^^^^^^^
KeyError: '169.254.2.1'
2025-11-19 10:44:04,106: 5.1-106.1 - ERROR : Failures in Job:1763549043 Exit Code:1 (Internal Failure)
admin@ecs1node1:~>
Cause
xDoctor は、制御ノードから起動する必要があります。通常、これはラック内の最初のノードです
このエラーが発生した場合、xDoctorは制御ノードを判別できず、実行を停止します。
このエラーは、ノードの拡張後に発生する可能性があります。
Resolution
Dellテクニカル サポートにお問い合わせの際は、サービス リクエストを作成し、このナレッジベース記事を参照してください。
Affected Products
ECSProducts
ECS Appliance, ECS Appliance Software with Encryption, ECS Appliance Software without EncryptionArticle Properties
Article Number: 000394248
Article Type: Solution
Last Modified: 09 Dec 2025
Version: 2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.