Data Domain: Causas comuns para o uso de espaço na partição /ddvar

Summary: O file system /ddvar (também conhecido como /ddr/var) é o local principal que o DDOS usa para armazenar logs. Este artigo da base de conhecimento descreve as causas comuns e as etapas a serem seguidas para ajudar a aliviar ou liberar espaço dentro de /ddvar ...

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Symptoms

O DDOS armazena vários arquivos de log dentro do file system /ddvar.

Para verificar o uso de espaço atual, o seguinte comando poderá ser usado, se estiver conectado ao sistema como um usuário com privilégios sysadmin:
filesys show space

Um exemplo de resultado do comando acima é o seguinte:

sysadmin@DD# filesys show space

Active Tier:
Resource           Size GiB   Used GiB   Avail GiB   Use%   Cleanable GiB*
----------------   --------   --------   ---------   ----   --------------
...
...
/ddvar                 49.1        7.4        39.2    16%                -
...
----------------   --------   --------   ---------   ----   --------------
Para verificar o uso atual de espaço usando o PowerProtect DD System Manager (DDSM) ou a interface gráfica do usuário (GUI):
  • Faça login no DDSM/GUI como um usuário com privilégios sysadmin
  • Selecione "Gerenciamento de dados" no menu à esquerda
  • Selecione "Sistema de arquivos" no submenu à esquerda
  • As informações são exibidas sob o título 'Partições do sistema'. Por exemplo:
ddem-data-management-file-system

Quando a utilização de espaço para /ddvar atinge 75%, o DDOS gera um alerta. Os alertas típicos de uso de espaço vistos para /ddvar são os seguintes:
  • EVT-SPACE-00003: Space usage in /ddvar has exceeded 85% threshold.
    EVT-SPACE-00003: Space usage in /ddvar has exceeded 90% threshold.
    EVT-SPACE-00003: Space usage in /ddvar has exceeded 95% threshold.
    EVT-SPACE-00003: Space usage in /ddvar has exceeded 100% threshold.
    EVT-SPACE-00004: Space usage in /ddvar has exceeded 85% threshold.
    EVT-SPACE-00004: Space usage in /ddvar has exceeded 90% threshold.
    EVT-SPACE-00004: Space usage in /ddvar has exceeded 95% threshold.
    EVT-SPACE-00004: Space usage in /ddvar has exceeded 100% threshold.

Cause

Causas comuns para o alto uso de espaço dentro do file system /ddvar são:
  • Pacotes de suporte antigos ou redundantes
  • Arquivos de upgrade antigos ou redundantes
  • Nível de registro CIFS não padrão O nível padrão de registro CIFS é 1.
  • Maior número de arquivos de log vtl.info e dfcuser.info presentes em /ddr/var/log/debug/ em formato descompactado.

Resolution

No DDOS 7.x, as seguintes opções existem para ajudar a resolver os pontos acima:
  • Para listar os pacotes de suporte presentes, o seguinte comando poderá ser usado se estiver conectado ao sistema como um usuário com privilégios sysadmin:
support bundle list

Um exemplo de resultado do comando acima é o seguinte:

 

sysadmin@DD# support bundle list
File                                          Size   Time Created
                                             (KiB)
-----------------------------------------   ------   ------------------------
DD-support-bundle-1120131912.tar.gz              0   Mon Nov 20 11:19:12 2017
DD-support-bundle-0807095325.tar.gz         712811   Tue Aug  7 05:53:25 2018
DD-support-bundle-0904051933.tar.gz         745409   Tue Sep  4 01:19:33 2018
DD-support-bundle-0925133541.tar.gz         663971   Tue Sep 25 09:35:41 2018
DD-support-files-0719130213.tar.gz              70   Thu Jul 19 09:02:13 2018
----------------------------------------- ------ ------------------------
  • Para excluir um pacote de suporte, a seguinte sintaxe de linha de comando pode ser usada se estiver conectado ao sistema como um usuário com privilégios sysadmin:
support bundle delete <name of support bundle obtained from 'support bundle list'>

Por exemplo:

support bundle delete DD-support-bundle-1120131912.tar.gz
  • Para listar qualquer pacote DDOS ou arquivos de upgrade presentes, o seguinte comando poderá ser usado, se estiver conectado ao sistema como um usuário com privilégios sysadmin:
system package list

Um exemplo de resultado do comando acima é o seguinte:

sysadmin@DD# system package list
File                                         Size (KiB)   Type     Class        Name        Version
------------------------------------------   ----------   ------   ----------   ---------   --------
7.11.0.0-1035502.rpm                          3885405.6   System   Production   DD OS       7.11.0.0
mdu_clp_cfg_patch_bundle-7.11-releases.rpm          7.2   Bundle   Production   DD-bundle   7.11.0.0
------------------------------------------   ----------   ------   ----------   ---------   --------
  • Para excluir um pacote do DDOS ou um arquivo de upgrade, a seguinte sintaxe de linha de comando pode ser usada se estiver conectado ao sistema como um usuário com privilégios sysadmin:
system package del <name of file obtained from 'system package list'>

Por exemplo:

system package del 7.11.0.0-1035502.rpm
  • O nível padrão de registro do CIFS é 1. Para verificar o nível de registro do CIFS, a seguinte sintaxe de linha de comando pode ser usada se estiver conectado ao sistema como um usuário com privilégios sysadmin:
cifs option show all

Um exemplo de resultado do comando acima é o seguinte:

sysadmin@dd3300-ddsupport# cifs option show all
All Options:

Option                                Value
-----------------------------------   -------------
...
...
loglevel                              1 (*)
...
...
-----------------------------------   -------------
(*) default value
  • Para definir ou redefinir o nível de registro do CIFS como 1, os seguintes comandos podem ser usados, se você estiver conectado ao sistema como um usuário com privilégios sysadmin:
cifs option reset loglevel
or

cifs option set loglevel 1
  • Para listar todos os pacotes de suporte do DDOS presentes via DDSM/GUI, as seguintes etapas podem ser usadas:
    • Faça log-in no DDSM/GUI como um usuário com privilégios sysadmin.
    • Selecione 'Manutenção' no menu à esquerda.
    • Selecione 'Suporte' no submenu à esquerda.
    • Selecione a guia "Support Bundles".
    • Por exemplo:
ddem-suporte-manutenção-01
  • Para excluir um pacote de suporte do DDOS via DDSM/GUI, as seguintes etapas podem ser usadas:
    • Faça log-in no DDSM/GUI como um usuário com privilégios sysadmin.
    • Selecione 'Manutenção' no menu à esquerda.
    • Selecione 'Suporte' no submenu à esquerda.
    • Selecione a guia "Support Bundles".
    • Marque um pacote de suporte ou vários pacotes de suporte a serem excluídos clicando com o botão esquerdo na caixa de seleção ao lado do nome do arquivo. Todos os pacotes de suporte podem ser marcados clicando com o botão esquerdo na caixa à esquerda do título "Nome do arquivo".
    • Depois que um pacote de suporte ou vários pacotes de suporte tiverem sido marcados, clique no botão "Excluir".
    • Um prompt será exibido listando o(s) pacote(s) de suporte a serem excluídos. Para excluir o(s) pacote(s) de suporte marcado(s), selecione o botão "OK".
    • Por exemplo:
ddem-suporte-manutenção-02 ddem-manutenção-suporte-03
 
  • Para listar qualquer pacote do DDOS ou arquivos de upgrade presentes via DDSM/GUI, as seguintes etapas podem ser usadas:
    • Faça log-in no DDSM/GUI como um usuário com privilégios sysadmin.
    • Selecione 'Manutenção' no menu à esquerda.
    • Selecione 'Sistema' no submenu à esquerda.
    • As informações serão exibidas no título 'Pacotes de upgrade disponíveis no sistema DD'.
    • Por exemplo:
ddem-manutenção-sistema
  • Para excluir um pacote do DDOS ou um arquivo de upgrade via DDSM/GUI, as seguintes etapas podem ser usadas:

    • Faça log-in no DDSM/GUI como um usuário com privilégios sysadmin.
    • Selecione 'Manutenção' no menu à esquerda.
    • Selecione 'Sistema' no submenu à esquerda.
    • Em "Upgrade Packages Available on DD System", marque um ou mais arquivos a serem excluídos clicando com o botão esquerdo na caixa de seleção ao lado do nome do arquivo. Todos os arquivos podem ser marcados clicando com o botão esquerdo na caixa à esquerda do título 'Nome do arquivo'.
    • Depois que um arquivo ou arquivos tiverem sido marcados, clique no botão "REMOVE UPGRADE PACKAGE".
    • Um prompt será exibido listando os arquivos a serem excluídos. Para excluir os arquivos marcados, selecione o botão "OK".
    • Por exemplo:
ddem-manutenção-sistema-remover-pacote-01 ddem-manutenção-sistema-remove-pacote-02
  • O nível padrão de registro do CIFS é 1. Para verificar o nível de registro do CIFS por meio do DDSM/GUI, as seguintes etapas podem ser usadas:
    • Faça log-in no DDSM/GUI como um usuário com privilégios sysadmin.
    • Selecione 'Protocolos' no menu à esquerda.
    • Selecione "CIFS" no submenu à esquerda.
    • No painel 'Options', o nível de log será exibido.
    • Nas versões mais antigas do DDOS, o nível de registro será exibido depois que você clicar no botão "Configure Options ".
    • Por exemplo:
ddem-protocolos-cifs-opções
  • Para definir ou redefinir o nível de registro CIFS como 1 por meio do DDSM/GUI, as seguintes etapas podem ser usadas:
    • Faça log-in no DDSM/GUI como um usuário com privilégios sysadmin.
    • Selecione 'Protocolos' no menu à esquerda.
    • Selecione "CIFS" no submenu à esquerda.
    • No painel 'Opções', clique em 'Configurar'. Em versões mais antigas do DDOS, clique no botão "Configure Options ".
    • Selecione "1" na seleção do número suspenso ao lado de "Nível de registro" ou clique na seta circular para redefinir o nível de registro de volta ao padrão 1. Nas versões mais antigas do DDOS, a seta circular é substituída por um texto "Padrão" clicável.
    • Clique no botão 'Salvar'. Nas versões mais antigas do DDOS, há um botão "OK".
    • Por exemplo:
ddem-protocols-cifs-options-modify

Vídeo: Causas comuns para o uso do espaço /ddvar:

Affected Products

Data Domain, DD OS
Article Properties
Article Number: 000217848
Article Type: Solution
Last Modified: 07 May 2024
Version:  3
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