Data Domain:/ddvar 分区中使用空间的常见原因

Summary: /ddvar(也称为 /ddr/var)文件系统是 DDOS 用于存储日志的主要位置。本知识库文章介绍了常见原因和帮助缓解或释放 /ddvar 中的空间的步骤

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

DDOS 在 /ddvar 文件系统中存储各种日志文件。

要检查当前空间使用情况,如果以具有 sysadmin 权限的用户身份登录到系统,则可以使用以下命令:
filesys show space

上述命令的示例输出如下所示:

sysadmin@DD# filesys show space

Active Tier:
Resource           Size GiB   Used GiB   Avail GiB   Use%   Cleanable GiB*
----------------   --------   --------   ---------   ----   --------------
...
...
/ddvar                 49.1        7.4        39.2    16%                -
...
----------------   --------   --------   ---------   ----   --------------
要使用 PowerProtect DD System Manager (DDSM) 或图形用户界面 (GUI) 检查当前空间使用情况,请执行以下操作:
  • 以具有 sysadmin 权限的用户身份登录到 DDSM/GUI
  • 从左侧菜单中选择“Data Management”
  • 从左侧子菜单中选择“File System”
  • 该信息显示在“系统分区”标题下。例如:
ddem-data-management-file-system

一旦 /ddvar 的空间利用率达到 75%,DDOS 就会生成警报。针对 /ddvar 显示的典型空间使用情况警报如下所示:
  • EVT-SPACE-00003: Space usage in /ddvar has exceeded 85% threshold.
    EVT-SPACE-00003: Space usage in /ddvar has exceeded 90% threshold.
    EVT-SPACE-00003: Space usage in /ddvar has exceeded 95% threshold.
    EVT-SPACE-00003: Space usage in /ddvar has exceeded 100% threshold.
    EVT-SPACE-00004: Space usage in /ddvar has exceeded 85% threshold.
    EVT-SPACE-00004: Space usage in /ddvar has exceeded 90% threshold.
    EVT-SPACE-00004: Space usage in /ddvar has exceeded 95% threshold.
    EVT-SPACE-00004: Space usage in /ddvar has exceeded 100% threshold.

Cause

/ddvar 文件系统中的高空间使用率的常见原因是:
  • 旧的或冗余的支持捆绑包
  • 旧的或冗余的升级文件
  • 非默认 CIFS 日志级别默认 CIFS 日志级别为 1。
  • /ddr/var/log/debug/ 下有大量未压缩的 vtl.info 和 dfcuser.info 日志文件。

Resolution

在 DDOS 7.x 中,存在以下选项来帮助解决上述问题:
  • 要列出存在的支持包,如果以具有 sysadmin 权限的用户身份登录到系统,则可以使用以下命令:
support bundle list

上述命令的示例输出如下所示:

 

sysadmin@DD# support bundle list
File                                          Size   Time Created
                                             (KiB)
-----------------------------------------   ------   ------------------------
DD-support-bundle-1120131912.tar.gz              0   Mon Nov 20 11:19:12 2017
DD-support-bundle-0807095325.tar.gz         712811   Tue Aug  7 05:53:25 2018
DD-support-bundle-0904051933.tar.gz         745409   Tue Sep  4 01:19:33 2018
DD-support-bundle-0925133541.tar.gz         663971   Tue Sep 25 09:35:41 2018
DD-support-files-0719130213.tar.gz              70   Thu Jul 19 09:02:13 2018
----------------------------------------- ------ ------------------------
  • 要删除支持包,如果以具有 sysadmin 权限的用户身份登录到系统,则可以使用以下命令行语法:
support bundle delete <name of support bundle obtained from 'support bundle list'>

例如:

support bundle delete DD-support-bundle-1120131912.tar.gz
  • 要列出存在的任何 DDOS 软件包或升级文件,如果以具有 sysadmin 权限的用户身份登录到系统,则可以使用以下命令:
system package list

上述命令的示例输出如下所示:

sysadmin@DD# system package list
File                                         Size (KiB)   Type     Class        Name        Version
------------------------------------------   ----------   ------   ----------   ---------   --------
7.11.0.0-1035502.rpm                          3885405.6   System   Production   DD OS       7.11.0.0
mdu_clp_cfg_patch_bundle-7.11-releases.rpm          7.2   Bundle   Production   DD-bundle   7.11.0.0
------------------------------------------   ----------   ------   ----------   ---------   --------
  • 要删除 DDOS 软件包或升级文件,如果以具有 sysadmin 权限的用户身份登录到系统,则可以使用以下命令行语法:
system package del <name of file obtained from 'system package list'>

例如:

system package del 7.11.0.0-1035502.rpm
  • 默认 CIFS 日志级别为 1。要检查 CIFS 日志级别,如果以具有 sysadmin 权限的用户身份登录到系统,则可以使用以下命令行语法:
cifs option show all

上述命令的示例输出如下所示:

sysadmin@dd3300-ddsupport# cifs option show all
All Options:

Option                                Value
-----------------------------------   -------------
...
...
loglevel                              1 (*)
...
...
-----------------------------------   -------------
(*) default value
  • 要将 CIFS 日志级别设置或重置为 1,可以使用以下命令(如果以具有 sysadmin 权限的用户身份登录到系统):
cifs option reset loglevel
or

cifs option set loglevel 1
  • 要列出通过 DDSM/GUI 存在的任何 DDOS 支持包,可以使用以下步骤:
    • 以具有 sysadmin 权限的用户身份登录 DDSM/GUI。
    • 从左侧菜单中选择“维护”。
    • 从左侧子菜单中选择“支持”。
    • 选择 “Support Bundles” 选项卡。
    • 例如:
ddem-maintenance-support-01
  • 要通过 DDSM/GUI 删除 DDOS 支持包,可以使用以下步骤:
    • 以具有 sysadmin 权限的用户身份登录 DDSM/GUI。
    • 从左侧菜单中选择“维护”。
    • 从左侧子菜单中选择“支持”。
    • 选择 “Support Bundles”选项卡。
    • 通过左键单击文件名旁边的复选框,标记要删除的一个或多个支持包。通过左键单击“File Name”标题左侧的框,可以标记所有支持包。
    • 标记一个或多个支持包后,单击“Delete”按钮。
    • 将出现一个提示,列出要删除的支持包。要删除标记的支持包,请选择“OK”按钮。
    • 例如:
ddem-maintenance-support-02 ddem-maintenance-support-03
 
  • 要列出通过 DDSM/GUI 提供的任何 DDOS 软件包或升级文件,可以使用以下步骤:
    • 以具有 sysadmin 权限的用户身份登录 DDSM/GUI。
    • 从左侧菜单中选择“维护”。
    • 从左侧子菜单中选择“System”。
    • 该信息将显示在“DD 系统上可用的升级软件包”标题下。
    • 例如:
ddem-maintenance-system
  • 要通过 DDSM/GUI 删除 DDOS 软件包或升级文件,可以使用以下步骤:

    • 以具有 sysadmin 权限的用户身份登录 DDSM/GUI。
    • 从左侧菜单中选择“维护”。
    • 从左侧子菜单中选择“System”。
    • 在“Upgrade Packages Available on DD System”下,通过左键单击文件名旁边的复选框标记要删除的文件。可以通过左键单击“文件名”标题左侧的框来标记所有文件。
    • 标记一个或多个文件后,单击 “REMOVE UPGRADE PACKAGE” 按钮。
    • 将出现一个提示,列出要删除的文件。要删除标记的文件,请选择“确定”按钮。
    • 例如:
ddem-maintenance-system-remove-package-01 ddem-maintenance-system-remove-package-02
  • 默认 CIFS 日志级别为 1。要通过 DDSM/GUI 检查 CIFS 日志级别,可以使用以下步骤:
    • 以具有 sysadmin 权限的用户身份登录 DDSM/GUI。
    • 从左侧菜单中选择“协议”。
    • 从左侧子菜单中选择“CIFS”。
    • 在“选项”窗格中,将显示日志级别。
    • 在较旧的 DDOS 版本中,单击 “配置选项” 按钮后将显示日志级别。
    • 例如:
ddem-protocols-cifs-options
  • 要通过 DDSM/GUI 将 CIFS 日志级别设置或重置为 1,可以使用以下步骤:
    • 以具有 sysadmin 权限的用户身份登录 DDSM/GUI。
    • 从左侧菜单中选择“协议”。
    • 从左侧子菜单中选择“CIFS”。
    • 在“选项”面板中,单击“配置”。在较旧的 DDOS 版本中,单击 “Configure Options” 按钮。
    • 从“Log Level”旁边的下拉数字选择 中选择“1”,或单击圆形箭头将日志级别重置回默认值 1。在较旧的 DDOS 版本中,圆形箭头被替换为可单击的“Default”文本。
    • 点击“保存”按钮。在较旧的 DDOS 版本中,有一个“OK”按钮。
    • 例如:
ddem-protocols-cifs-options-modify

视频:/ddvar 空间使用情况的常见原因:

Affected Products

Data Domain, DD OS
Article Properties
Article Number: 000217848
Article Type: Solution
Last Modified: 07 May 2024
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.