AppSync: AppSync 4.3.0.0 og 4.3.0.1 utfører nå en gratis All cCmmand ved frakobling av målenheter for SnapVX-kopier.

Summary: AppSync 4.3.0.0 og 4.3.0.1 utfører nå en Free All-kommando når du kobler fra målenheter for SnapVX-kopier. Versjon 4.3.0.1 utfører også en Free All-kommando når en PowerMax- eller VMAX-kopi utløper. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

I henhold til brukerhåndboken for AppSync 4.3, side 284:
Unlink the SnapVX snapshots during unmount mount option also frees up the unlinked target devices in protection copies and second generation repurposing copies.
NOTE: Freeing up of devices is not guaranteed. The service plan waits for a maximum of five minutes for freeing up unlinked target devices, and then resume.
Hvis kommandoen Free All ikke fullføres innen fem minutter, kan AppSync be om å montere på nytt og bruke de samme målenhetene på nytt. Når koblingen blir forespurt, kan den mislykkes siden Free All fortsatt kjører.

I dette tilfellet viser hendelsene for serviceplanen mens du utfører en montering, følgende:
VMAX_000070,host,The SnapVX snapshot AS_Daily_namexx_Jul_30_at_06_02_40 is establishing link with target devices, for the source and target pair(s) 00011:00022, 00033:00044, on storage array 00019760xxxx.

Mount copy, VMAX_000002,host,VMAX operation failed. Error: Exception thrown while linking the copy Information not available for the job or job is not running. Considered job failed :FAILED and reason:The action cannot be performed because all device allocations are being freed 

Cause

Innføringen av kommandoen Free All er en ny funksjon som ble lagt til AppSync 4.3.0.0 og finnes også i 4.3.0.1.

Resolution

For 4.3.0.0
:Gratis alt gjøres på frakoblingstidspunktet.
Fjern merket for "unlink" i monteringsfasen av serviceplanen for å sikre at Gratis Alt ikke blir gjort under frakoblingen under demontering.

En hurtigreparasjon er tilgjengelig for AppSync 4.3.0.0 som introduserer en avansert AppSync-innstilling, som kan settes til "True" for å hoppe over koblingen til GRATIS ALL ved frakobling. Kontakt Dell Support for å få hurtigreparasjonen. Nevn dette artikkelnummeret når du ringer inn en serviceforespørsel for å få hurtigreparasjonen.
 
Hurtigreparasjonen introduserer følgende avanserte AppSync-innstilling:
"vmax.skip.freeup.target.device"

Sett den til "true" for å hoppe over målenheten som er frigjort under frakoblingen ved demontering.


For versjon 4.3.0.1 og 4.4.0.0
:Gratis Alt gjøres under utløpet.
Følgende AppSync Advanced Setting ble introdusert i 4.3.0.1.
"vmax.freeup.target.device"  
 
Hvis satt til True, en Free All er ferdig når en kopi er utløpt.
Sett den til False for å få AppSync til ikke å utføre en Free All på utløpstidspunktet.

Versjon 4.3.0.1 og 4.4.0.0 bruker ikke AppSync Advanced Setting "vmax.skip.freeup.target.device."

Notat: AppSync Advanced Settings finner du i brukergrensesnittet ved å klikke på "Settings" øverst til høyre på skjermen, og deretter "Advanced Settings" på venstre side.

Additional Information

Restating for å sikre klarhet for 4.3.0.1 og 4.4.0.0
  • 4.3.0.1 og 4.4.0.0 sender GRATIS ALLE under UTLØP hvis følgende enkeltbetingelse er på plass:
Systemvariabelen vmax.freeup.target.device er satt til SANN.
Sett til USANN for ikke å gjøre GRATIS ALLE som utløper.

Den andre AppSync-systeminnstillingen med ordet hopp over i den: vmax.skip.freeup.target.device brukes ikke av versjon 4.3.0.1 eller nyere.

Nedenfor er et eksempel fra AppSync-serverloggen som viser at AppSync sender en REE ALL-kommando til VMAX.
10-05-2021 19:02:22.333 INFO ... ->>> Executing PUT /univmax/restapi/92/sloprovisioning/symmetrix/000008675309/volume/00123 request in REST interface :My.U4P.com
10-05-2021 19:02:22.349 INFO ... ->>> The payload data is :{
  "editVolumeActionParam" : {
    "freeVolumeParam" : {
      "free_volume" : true
    },
    "modifyVolumeIdentifierParam" : null
  }
}

Products

AppSync
Article Properties
Article Number: 000190982
Article Type: Solution
Last Modified: 18 Sep 2025
Version:  9
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.