Dell Unity:NFSv4 無法掛接以匯出路徑,NFSv3 成功。(使用者可修正)

Summary: 本文說明嘗試使用 NFSv4 掛接時掛接失敗的原因之一,並顯示「沒有該檔案或目錄」。

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

當共用名稱包含「/」字元時,具有匯出路徑的 NFSv4 掛接失敗。
mount -o vers=4 xx.xx.xx.xx:/<share name contains "/"> /mnt/nfsv4
mount.nfs: mounting xx.xx.xx.xx:/<share name contains "/"> failed, reason given by server: No such file or directory
嘗試使用 NFSv3 掛接至相同的匯出路徑成功。

Cause

NFSv4 用戶端無法掛接包含「/」字元的共用名稱。

Unisphere CLI 說明文件指出如下:
NFSv4 用戶端無法使用包含「/」字元的名稱掛接共用。
相反,客戶端必須使用共享路徑。

Resolution

如果符合上述條件,請使用共用路徑 (本機路徑) 而非共用名稱 (匯出路徑) 進行掛接。

Additional Information

以下是 NFS 共用名稱包含“/”的範例。
此為 Unisphere UI 畫面的範例,其中包含
在此範例中,如果檔案系統下有一個名為「/AAA/CCC」的資料夾,則會在嘗試使用 NFSv4 掛接時掛接該資料夾。
如果檔案系統下沒有資料夾「/AAA/CCC」,則會顯示「沒有此類檔案或目錄」錯誤。

使用 NFS 版本 3 以「匯出路徑」掛接
# mount -o vers=3 xx.xx.xx.xx:/AAA/CCC /mnt/nfsv3
使用 NFS 版本 4 以「匯出路徑」掛接
# mount -o vers=4 xx.xx.xx.xx:/AAA/CCC /mnt/nfsv4
mount.nfs: mounting xx.xx.xx.xx:/AAA/CCC failed, reason given by server: No such file or directory
使用 NFS 版本 4 以「本機路徑」掛接
# mount -o vers=4 xx.xx.xx.xx:/testfs/AAA/BBB/CCC /mnt/nfsv4

Affected Products

Dell EMC Unity, Dell Unity 450F DC, Dell Unity 300, Dell Unity 300 DC, Dell EMC Unity 300F, Dell EMC Unity 350F, Dell Unity 350F DC, Dell EMC Unity XT 380, Dell EMC Unity XT 380F, Dell EMC Unity 400, Dell Unity 400 DC, Dell EMC Unity 400F , Dell EMC Unity 450F, Dell EMC Unity XT 480, Dell EMC Unity XT 480F, Dell EMC Unity 500, Dell EMC Unity 500F, Dell EMC Unity 550F, Dell EMC Unity 600, Dell EMC Unity 600F, Dell EMC Unity 650F, Dell EMC Unity XT 680, Dell EMC Unity XT 680F, Dell EMC Unity XT 880, Dell EMC Unity XT 880F, Dell EMC Unity Family |Dell EMC Unity All Flash, Dell EMC Unity Family, Dell EMC Unity Hybrid, Dell EMC UnityVSA Professional Edition/Unity Cloud Edition ...
Article Properties
Article Number: 000224159
Article Type: Solution
Last Modified: 06 Aug 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.