Unity: Performance Dashboard CSV Export Fails When Language Pack Is Applied

Summary: This article provides a workaround for the issue where Performance Dashboard information cannot be downloaded in Comma-Separated Value (CSV) format when a Language Pack is applied. (User Correctable) ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Exporting performance graphs in CSV format consistently fails when a language pack is applied and graph names contain non-English characters.

Cause

The limitation of the export filename was modified in version 5.4 for security reasons, resulting in failures when using non-English characters.

Resolution

The fix is in Unity OE version 5.5 and later.

Workaround:
Entering the graph name in English enables the download of graph data in CSV format.

Alternatively, selecting Export Chart Data from the Historical Charts menu allows chart data to be downloaded as a CSV file.

The reason is that the CSV filename is generated using English characters in this scenario.

This is the menu for exporting information from Historical Charts in the Unisphere UI.

Additional Information

This issue has not been observed in Unity OE versions prior to 5.3, nor has it been reported in versions 5.5 and later.

When attempting to investigate by collecting logs, see the following article for guidance on collecting HTTP Archive (HAR) files: How To: Collect HAR files from Google Chrome (Log in as a registered Dell Support user may be required to view this article.)

Affected Products

Dell EMC Unity, Dell EMC Unity Family |Dell EMC Unity All Flash, Dell EMC Unity Hybrid
Article Properties
Article Number: 000358655
Article Type: Solution
Last Modified: 02 Oct 2025
Version:  3
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