Přihlašovací údaje pro připojení k nástroji PowerProtect Data Manager Hyper-V

Summary: Tento článek znalostní databáze popisuje požadavky na účet pro přidání zdroje prostředků serveru Hyper-V nebo clusteru v nástroji PowerProtect Data Manager.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Při přidávání zdroje prostředků serveru nebo clusteru Hyper-V pomocí uživatele domény je nutné přiřadit uživatelskému účtu domény služby Active Directory (AD) následující oprávnění, aby bylo možné spustit zálohování a obnovení virtuálního počítače Hyper-V (VM):

Samostatný:

  • Místní skupina správců
  • Skupina správců technologie Hyper-V
  • Uživatelé vzdálené správy
  • Uživatelé vzdálené plochy

Shluk:

  • Místní skupina správců
  • Skupina správců technologie Hyper-V
  • Uživatelé vzdálené správy
  • Uživatelé vzdálené plochy
  • Přístup pro čtení/zápis clusteru 
    Grant-clusteraccess -user <Domain\user> -Full

I když jsou oprávnění poskytnuta, funkce File Level Recovery (FLR) se nepodaří připojit zálohu s následující chybou:

2025-06-30T12:50:51.928Z ERROR [98d1d5f0658a4101;b774b4be3e4a26b8] - Exception occurred while handling flrAttach request: ADHP0002 
2025-06-30T12:50:51.928Z ERROR [98d1d5f0658a4101;b774b4be3e4a26b8] - Inner exception: Connecting to remote server hyperv-01 failed with the following error message : Access is denied. For more information, see the about_Remote_Troubleshooting Help topic. 
2025-06-30T12:50:51.941Z INFO [98d1d5f0658a4101;b774b4be3e4a26b8] - Pluginservice attach response: 
{
  "DiskControllers": null,
  "Status": "FAILURE",
  "Error": {
    "Code": 400,
    "ExtendedInfo": "",
    "Path": "",
    "Reason": "Attach operation cannot be completed because an Exception error occurred.",
    "Remediation": "To troubleshoot the issue:\n1) In the PowerProtect Data Manager UI, go to the Jobs window and click Export log and review the log file for more details.\n2) Retry the operation.\nIf the issue persists, contact Dell Customer Support.",
    "Timestamp": 638868882519312362,
    "MessageId": "ARHV0033",
    "MessageArgs": null,
    "MessageTemplate": null,
    "Message": "ADHP0002"
  }
} 

Cause

Účet použitý pro přidání použitého formátu Hyper-V byl <uživatelské jméno> bez jakékoli předpony.

Během funkce FLR připojí název počítače před uživatelské jméno připojení. Výsledkem je použití místního účtu (název hostitele\uživatelské jméno) namísto účtu domény (doména\uživatelské_jméno).

Místní účet nemá požadovaná oprávnění.

Chcete-li to ověřit, zkontrolujte, zda lze provést připojení winrm z vnějšku aplikace.

Pomocí skriptu PowerShellu obsahujícího příkazy ručně vytvořte připojení winrm.
Upravte proměnné skriptu a přidejte podrobnosti o serveru Hyper-V – plně kvalifikovaný název domény /IP, uživatelské jméno zálohy a heslo.
Spusťte tento skript v prostředí PowerShell ISE na serveru Hyper-V (uzel vlastníka cílového virtuálního počítače), u kterého dochází k selhání funkce FLR.

Vyzkoušejte skript pomocí plně kvalifikovaného názvu domény (FQDN), IP adresy a krátkého názvu. Poté zkontrolujte, s jakou kombinací funguje připojení winrm pro tento server Hyper-V. Zkuste to pro místní účet a účet domény,

Zkuste také do pole uživatelského jména zadat uživatelské jméno ntstyle a styl hlavního názvu uživatele (UPN).
Ntstyle: doména\správce
UPN: adminitrator@domain.com
 

Resolution

V případě uživatele domény by přihlašovací údaje uživatele měly mít jeden z následujících formátů:

username@domain.comnebo ntname\uživatelské jméno

Upravte styl uživatele v přihlašovacích údajích pro správu > uživatelského rozhraní > PowerProtect Data Manager

Additional Information

Ze skriptu PowerShell: 

$hostName="10.125.xx.xx" # example: "mywindowsvm.westus.cloudapp.azure.com ( IP /FQDN of the HYPERV server)"
$winrmPort = "5986"
$cred = New-Object System.Management.Automation.PSCredential("netbiosname\Username", (ConvertTo-SecureString 'Password123' -AsPlainText -Force))
# Connect to the machine
$sessionOptions = New-PSSessionOption -SkipCACheck -SkipCNCheck -SkipRevocationCheck
Enter-PSSession -ComputerName $hostName -Port $winrmPort -Credential $cred  -UseSSL -SessionOption


 

Article Properties
Article Number: 000359505
Article Type: Solution
Last Modified: 20 Jan 2026
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.