PowerPath para Windows: Windows muestra el disco duro?? en PowerPath

Resumen: Windows muestra el disco duro?? en PowerPath

Este artículo se aplica a Este artículo no se aplica a Este artículo no está vinculado a ningún producto específico. No se identifican todas las versiones del producto en este artículo.

Síntomas

Por lo general, esto se ha observado cuando se ha producido una actividad de migración de un conjunto de discos a otro conjunto de discos. Sin embargo, hay otras causas.

PowerPath para Windows muestra el disco duro?? en la GUI de PowerPath o en powermt display dev=all.

El dispositivo es visible en el nivel de HBA y también en el nivel de MPIO.

Causa

Parece que el LDM de Windows está comprometido de alguna manera.

Resolución

Asegúrese de que el archivo powermt.custom o powermt.custom.xml se haya eliminado de las carpetas c:\program files\EMC\powercommon o c:\program files\EMC\PowerPath (según la versión de PowerPath) antes de llevar a cabo cualquiera de las siguientes opciones.

Opción 1: cualquiera de estos pasos puede proporcionar una resolución; sin embargo, si no lo hacen, se deberá realizar la opción 2 o la opción 3.
1) Elimine powermt.custom.xml archivo y reinicie.
2) Busque cambios de hardware en el administrador de dispositivos.
3) Comprobación de reconfiguración de PowerMT 

Opción 2:
1) Elimine los dispositivos sospechosos de la visibilidad del host.
2) Abra un símbolo del sistema (haga clic con el botón secundario y ejecute como administrador).
Luego, ejecute los siguientes 2 comandos en el símbolo del sistema:
Establecer devmgr_show_nonpresent_devices=1
Inicie devmgmt.msc
Esto abrirá el administrador de dispositivos.
3) Seleccione la opción de menú "Ver" y "Mostrar dispositivos ocultos".
4) Expanda la sección de disco del árbol.
5) Haga clic con el botón secundario y desinstale todos los dispositivos de disco atenuados (incluidos todos los dispositivos PowerPath).
6) Cuando se complete el reinicio.
7) Haga que los dispositivos vuelvan a ser visibles para el host.
8) Realice un análisis para detectar cambios de hardware en el administrador de dispositivos.

Opción 3
1) Quite todos los dispositivos externos de la visibilidad del host.  Nota: Si el host arranca desde SAN, el dispositivo de arranque necesariamente deberá mantenerse visible para el host en la ruta de arranque principal.
2) Desinstale PowerPath y reinicie.
3) Abra un símbolo del sistema (haga clic con el botón secundario y ejecute como administrador):
Luego ejecute los siguientes 2 comandos en el símbolo del sistema:
Establecer devmgr_show_nonpresent_devices=1
Inicie devmgmt.msc
Esto abrirá el administrador
de dispositivos 4) Seleccione el elemento de menú "Ver" "Mostrar dispositivos ocultos"
5) Expanda la sección de disco del árbol.
6) Haga clic con el botón secundario y desinstale todos los dispositivos de disco atenuados (incluidos todos los dispositivos PowerPath).
7) Cuando se complete el reinicio.
8) Vuelva a hacer que los dispositivos sean visibles para el host.
9) Instale PowerPath y reinicie.

Información adicional

Si MPIO no reclama dispositivos correctamente (sin PowerPath instalado), una rutina equivalente para MPIO es
: 1) Quitar todos los dispositivos externos de la visibilidad del host.  
2) deshabilite/desinstale la función MPIO de Microsoft y reinicie
3) Abra un símbolo del sistema (haga clic con el botón secundario y ejecute como administrador):
Luego ejecute los siguientes 2 comandos en el símbolo del sistema:
Set devmgr_show_nonpresent_devices=1
Inicie devmgmt.msc
Esto abrirá el administrador
de dispositivos 4) Seleccione el elemento de menú "Ver" "Mostrar dispositivos ocultos"
5) Expanda la sección de disco del árbol.
6) Haga clic con el botón secundario y desinstale todos los dispositivos
de disco atenuados 7) Cuando haya completado el reinicio.
8) Vuelva a hacer que los dispositivos sean visibles para el host.
9) Escanee los cambios de hardware en el administrador de
dispositivos 10) Habilite/instale MPIO y reinicie

 

Productos afectados

PowerPath for Windows

Productos

PowerPath for Windows
Propiedades del artículo
Número del artículo: 000050184
Tipo de artículo: Solution
Última modificación: 17 abr 2026
Versión:  5
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.