NetWorker: Fout 'Kan geen gebruikersrechten instellen op basis van gebruikerstoken voor account_name op nw_server_name' verschijnt
Resumen: Deze fout kan optreden wanneer de op tijd gebaseerde tokenverificatie die wordt gebruikt door de authc-server van de NetWorker-server, is verlopen. Dit wordt weergegeven wanneer u NetWorker-opdrachten probeert uit te voeren vanaf de NetWorker-server. ...
Este artículo se aplica a
Este artículo no se aplica a
Este artículo no está vinculado a ningún producto específico.
No se identifican todas las versiones del producto en este artículo.
Síntomas
Wanneer u NetWorker-opdrachten probeert uit te voeren op de NetWorker-server, wordt een pop-up weergegeven waarin staat dat de NetWorker-server het beveiligingstoken niet heeft gevalideerd.
Voorbeeld:
C:\>nsrim -X
C:\>nsrim -X
10074:nsrim: can't binding to NSR service on Server name 144502:nsrd: Kan geen gebruikersrechten instellen op basis van het gebruikerstoken voor account_name op nw_server_name: Kan beveiligingstoken niet valideren.
Causa
NetWorker maakt gebruik van op tijd gebaseerde verificatietokens. Als de nsrlogin eerder is uitgegeven voor een NetWorker-gebruikersaccount, kunt u geen NetWorker-opdrachten uitvoeren zodra het token is verlopen. Er moet een nieuw token worden uitgegeven of u moet nsrlogout gebruiken om terug te keren naar verificatie op besturingssysteemniveau. Met verificatie op besturingssysteemniveau kunt u alleen NetWorker-opdrachten uitvoeren vanaf een beheerdersopdrachtprompt of rootsessie.
Resolución
(Optie 1) Terugkeren naar legacy verificatie:
- Als dit probleem zich alleen voordoet wanneer u NetWorker-serveropdrachten probeert uit te voeren, kunt u terugkeren naar de (legacy) OS-gebaseerde verificatie die door NetWorker wordt gebruikt. Dit probleem doet zich voor omdat de opdracht nsrlogin is uitgevoerd op de NetWorker-server en het token is verlopen. Als u wilt terugkeren naar de verouderde verificatie, voert u nsrlogout uit op de NetWorker-server.
(Optie 2) Geef een nieuw authc-token uit:
- Als u een nieuw token wilt toekennen aan de NetWorker-server, voert u de volgende opdracht uit:
Het Administrator-account is het standaard NetWorker Administrator-account en -wachtwoord; Elk NetWorker-gebruikersaccount kan echter wel een token uitgeven met nsrlogin als de gebruiker de rollen Application Administrator en Security Administrator heeft.
Als externe LDAP/AD-verificatie is geconfigureerd, moet u het domein en de tenant opgeven (als de standaardtenant niet is gebruikt).
- Als dit probleem zich alleen voordoet wanneer u NetWorker-serveropdrachten probeert uit te voeren, kunt u terugkeren naar de (legacy) OS-gebaseerde verificatie die door NetWorker wordt gebruikt. Dit probleem doet zich voor omdat de opdracht nsrlogin is uitgevoerd op de NetWorker-server en het token is verlopen. Als u wilt terugkeren naar de verouderde verificatie, voert u nsrlogout uit op de NetWorker-server.
(Optie 2) Geef een nieuw authc-token uit:
- Als u een nieuw token wilt toekennen aan de NetWorker-server, voert u de volgende opdracht uit:
Syntax: nsrlogin [-s NetWorker_server] [-H authentication_host] [-P port] [-t tenant] [-d logindomain] -u username [-p "password"]
Example: nsrlogin -u Administrator -p password
Example: nsrlogin -u Administrator -p password
Het Administrator-account is het standaard NetWorker Administrator-account en -wachtwoord; Elk NetWorker-gebruikersaccount kan echter wel een token uitgeven met nsrlogin als de gebruiker de rollen Application Administrator en Security Administrator heeft.
Als externe LDAP/AD-verificatie is geconfigureerd, moet u het domein en de tenant opgeven (als de standaardtenant niet is gebruikt).
Información adicional
Meer informatie over nsrlogin vindt u in de NetWorker Command Reference en NetWorker Administrator Guides die beschikbaar zijn via: https://www.dell.com/support/home/product-support/product/networker/docs
Productos afectados
NetWorkerProductos
NetWorkerPropiedades del artículo
Número del artículo: 000065549
Tipo de artículo: Solution
Última modificación: 10 jun 2025
Versión: 4
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.