RESTAPI-aanroepen worden te langzaam geretourneerd, wat leidt tot VSS-time-outfouten in AppSync
Resumen: RESTAPI-aanroepen worden te langzaam geretourneerd, wat leidt tot VSS-time-outfouten in AppSync
Este artículo se aplica a
Este artículo no se aplica a
Este artículo no está vinculado a ningún producto específico.
No se identifican todas las versiones del producto en este artículo.
Síntomas
Klant die AppSync met RESTAPI gebruikt om snapshots te maken op Windows 2016-hosts. Het maakt gebruik van Microsoft VSS die binnen 10 seconden een reactie moet ontvangen. De RESTAPI heeft meer tijd nodig voor de respons, zelfs als de snapvx-sessie in minder dan 1 seconde wordt voltooid.
In de AppSync-logboeken zien we het snap-verzoek en kort daarna wordt de start van snapvx in de SYMAPI-logboeken weergeven. De snap wordt in minder dan een seconde uitgevoerd. De respons van de RESTAPI naar AppSync vindt echter pas plaats 30 seconden nadat de snap is voltooid. We kunnen het volgende zien in de SMAS- en RESTAPI-logboeken (INFO-registratie vereist op Unisphere):
INFO [em.bp.RESTAPIUSAGE] (default task-611) /private/91/replication/symmetrix/{symmetrixId}/snapshot/{snapshotName} AppSync/4.1.0.1_2492_R2/<IP_address> POST 36829 ms 201 null null null
In de AppSync-logboeken zien we het snap-verzoek en kort daarna wordt de start van snapvx in de SYMAPI-logboeken weergeven. De snap wordt in minder dan een seconde uitgevoerd. De respons van de RESTAPI naar AppSync vindt echter pas plaats 30 seconden nadat de snap is voltooid. We kunnen het volgende zien in de SMAS- en RESTAPI-logboeken (INFO-registratie vereist op Unisphere):
INFO [em.bp.RESTAPIUSAGE] (default task-611) /private/91/replication/symmetrix/{symmetrixId}/snapshot/{snapshotName} AppSync/4.1.0.1_2492_R2/<IP_address> POST 36829 ms 201 null null null
Causa
In dit geval is dit probleem waargenomen wanneer de klant snapshots van afzonderlijke apparaten heeft gemaakt in plaats van op het storagegroepniveau. Er werden snapshots van meer dan 50 apparaten gemaakt, wat heeft bijgedragen aan de tijd die nodig was om de RESTAPI-query te retourneren naar AppSync.
Engineers hebben getracht dit probleem te omzeilen door een wijziging in de architectuur te ontwikkelen waarmee RESTAPI-aanroepen reageren binnen de time-out van 10 seconden van VSS.
Engineers hebben getracht dit probleem te omzeilen door een wijziging in de architectuur te ontwikkelen waarmee RESTAPI-aanroepen reageren binnen de time-out van 10 seconden van VSS.
Resolución
Oplossing: Er is een hotfix beschikbaar om dit probleem te omzeilen. Er is een hotfix voor zowel Unisphere als AppSync die nodig zijn om dit probleem op te lossen. Neem contact op met support, verwijs naar dit KB-artikel en vraag om de volgende oplossingen:
- Unisphere for PowerMax 9.2.0.9
- AppSync patch 4.1.0.1_2492_R3
Beide oplossingen zijn vereist om dit probleem te omzeilen.
- Unisphere for PowerMax 9.2.0.9
- AppSync patch 4.1.0.1_2492_R3
Beide oplossingen zijn vereist om dit probleem te omzeilen.
Productos afectados
Unisphere for PowerMaxPropiedades del artículo
Número del artículo: 000182815
Tipo de artículo: Solution
Última modificación: 06 nov 2025
Versión: 6
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.