NetWorker Module for Microsoft: "Named Pipes Provider: Could not open a connection to SQL Server [2]" 오류와 함께 SQL 백업 실패
Resumen: SQL Server가 클라이언트 측에서 응답하지 않거나 응답을 중지하여 SQL 백업이 실패했습니다. 또한 SQL Server에서 SQL 데이터베이스를 나열할 수 없습니다. NMC에서 장애가 발생하면 38008: nsrsqlsv: Named Pipes Provider: Could not open a connection to SQL Server [2] 오류와 함께 실패합니다. ...
Este artículo se aplica a
Este artículo no se aplica a
Este artículo no está vinculado a ningún producto específico.
No se identifican todas las versiones del producto en este artículo.
Síntomas
-
SQL 백업이 실패하고 아래 오류 메시지가 표시됩니다.
38571:nsrsqlsv: Bad switch: -o 38562:nsrsqlsv: Unsupported savegrp option -o will be ignored 153887:nsrsqlsv: Microsoft SQL server documentation provides details about the following SQL Server Provider error: 38008:nsrsqlsv: Named Pipes Provider: Could not open a connection to SQL Server [2]. 153416:nsrsqlsv: (Error: 2)
- NMM(NetWorker Module for Microsoft) 클라이언트에서 nsrsqlsv 로그는 'C:\Program Files\EMC NetWorker\nsr\applogs\nsrsqlsv.log' 아래에 세부 정보를 포함합니다.
Causa
이 문제는 VSS writer가 안정적이지 않기 때문에 발생합니다.
이 문제는 SQL Server Services가 제대로 응답하지 않기 때문이기도 합니다.
이 문제는 SQL Server Services가 제대로 응답하지 않기 때문이기도 합니다.
Resolución
- SQL 클라이언트에서 SQL Server Service를 재시작합니다.
Windows:
net start MSSQLSERVER
참고: 이 문제에 대한 추가 정보는 다음 Microsoft 문서를 참조하십시오.
https//docs.microsoft.com/en-us/sql/database-engine/configure-windows/start-stop-pause-resume-restart-sql-server-services?view=sql-server-ver15#:~:text=SQL%20Server%20Management%20Studio,-Start%2C%20stop%2C%20pause&text=Or%2C%20in%20Registered%20Servers%2C%20right,Pause%2C%20Resume%2C%20or%20Restart.
- NetWorker 클라이언트 서비스를 재시작하고 오래된 프로세스가 있는지 확인합니다(있는 경우).
- NetWorker 서비스를 시작하거나 중지하려면 다음을 수행합니다.
net stop nsrexecd /y && net start nsrexecd
- 오래된 프로세스를 확인하는 방법:
tasklist | findstr nsr
- 프로세스를 종료하는 방법:
tskill
참고: PID는 작업 목록 출력의 서비스 데몬 옆에 생성됩니다.
Propiedades del artículo
Número del artículo: 000199292
Tipo de artículo: Solution
Última modificación: 06 ene 2026
Versión: 4
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.